Fedora 39 GPU has fallen off the bus

Hello everyone! A week ago I installed Fedora 39. During the installation, there were some hang-ups, so I installed it using the “basic” graphics driver mode.( Fedora 39 freezes during installation).
Later on, I installed old drivers for Nvidia from rpm fusion because I have an old Nvidia 550Ti graphics card.

rpm -qa |grep nvidia
xorg-x11-drv-nvidia-390xx-kmodsrc-390.157-3.fc39.x86_64
nvidia-settings-390xx-390.157-2.fc39.x86_64
xorg-x11-drv-nvidia-390xx-libs-390.157-3.fc39.x86_64
xorg-x11-drv-nvidia-390xx-390.157-3.fc39.x86_64
akmod-nvidia-390xx-390.157-6.fc39.x86_64
kmod-nvidia-390xx-6.7.6-200.fc39.x86_64-390.157-6.fc39.x86_64
kmod-nvidia-390xx-6.7.7-200.fc39.x86_64-390.157-6.fc39.x86_64
nvidia-gpu-firmware-20240220-1.fc39.noarch

After hanging once, LibreOffice froze. Then, while I was looking for a way to get the webcam to work, Linux worked without problems for a week! Fedora 39 does not detect the Logitech Brio 4K webcam. Fedora 39 does not detect the Logitech Brio 4k device

Today, constant freezes began. It hangs without any load, just open LibreOffice or Google Chrome and it hangs. At the same time, it is possible to log in via SSH. The Xorg process works 100%. It does not get killed, even with kill -9. If the computer is remotely rebooted using “shutdown -r now”, the computer does not reboot, only access via SSH disappears.

The conclusion from dmesg:

NVRM: GPU at PCI:0000:01:00: GPU-656da171-d6ad-eaf8-9320-1448da66dea7
[  +0,000008] NVRM: Xid (PCI:0000:01:00): 79, GPU has fallen off the bus.
[  +0,000001] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[  +0,000011] NVRM: A GPU crash dump has been created. If possible, please run
              NVRM: nvidia-bug-report.sh as root to collect this data before
              NVRM: the NVIDIA kernel module is unloaded.

One would think it’s a hardware problem with the graphics card, BUT Fedora didn’t freeze for a whole week. There are no problems in Windows. And the main thing is it freezes only under one user (my son without sudo rights) and only from programs like LibreOffice and Google Chrome. It doesn’t freeze under Firefox. It also doesn’t freeze under another user (also without sudo). I tried using the system under my own user…

In the topic about the webcam not working on a USB 3.0 port, there was a suggestion that it might be a power-saving issue. I googled that Nvidia crashes could be due to insufficient power supply. In GNOME, I set the power-saving mode to “Performance”, but it didn’t help. I also fully updated Fedora through dnf update. Any ideas? Besides a hardware problem with the graphics card?

If 5gos is a desktop system you can try removing the gpu, cleaning the slot with compressed air, then reinstall the gpu.
If you do not have compressed air just remove and install the gpu.

It may help if the issue is dust particles making contacts intermittent.

The system is using the 390xx driver. At that driver level it will ONLY run the xorg DE. That driver does not support a wayland DE.

Is your son trying to use wayland? If so then that would seem the likely cause. If not then a little more trouble shooting may be needed.

Please post the output of inxi -Fzxx so we can see the full system config.