Fedora 39 and broadcom-wl

Hello all, i have installed fedora 39 on a (old) macbook 6.1 for my daughter (9 years old), who she really likes fedora environment :slight_smile:
Only problem i have is about broadcom-wl drivers, cause every time there is a kernel upgrade stops to work and i have to add again with a modprobe-wl and other stuff i don´t remember now.
Wondering if there is a way to do enable broadcom-wl driver automatically after a change of kernel (i remember in Debian was automatic using dkms but i am not able to do in Fedora ) - OR instead if would be better to stop kernel updates and keep one i have now, considering that hardware is really old and that my daughter just need a stable system.
thanks for any feedback

If you installed the broadcom-wl driver from rpmfusion then a kernel update should also automatically update the driver. Where did you obtain the broadcom-wl driver?

As far as keeping the version and software up to date, the updates are recommended for security if the machine has access to the internet. It is quite possible to halt updates if you choose but you must decide between security and updates or no updates when allowing your daughter to access the internet.

The post by Flo below gives the details and the broadcom issue is related to the akmod-wl package which creates the kmod-wl package. Similarly to the issue with rebuilding the kmod-nvidia-* packages that can be directly related to rebuilding the kmod-wl-* packages. The same 3 steps apply with the package name changed.

Personally I have only seen this issue appear in 2 situations.

  1. A quick reboot after a routine update (including the automatic offline updates)
    (I stopped automatic updates for this reason, and I wait several minutes after doing a manual update before rebooting)
  2. the first reboot after a system version upgrade.

With manually controlled updates and delaying the next reboot the problem does not appear for me.

1 Like

The problem and its workaround is described under Third-party modules (e.g. Nvidia) are not rebuilt during system upgrade

1 Like

My daily driver is an old iMac. I use:

Installed packages
Name            : broadcom-wl
Epoch           : 0
Version         : 6.30.223.271
Release         : 22.fc39
Architecture    : noarch
Installed size  : 38.4 KiB
Source          : broadcom-wl-6.30.223.271-22.fc39.src.rpm
From repository : rpmfusion-nonfree
Summary         : Common files for Broadcom 802.11 STA driver
URL             : https://www.broadcom.com/support/download-search?pg=Legacy+Products&pf=Legacy+Wireless&pn=&pa=&po=&dk=
                : &pl=
License         : Redistributable, no modification permitted
Description     : This package contains the license, README.txt and configuration
                : files for the Broadcom 802.11 Linux STA Driver for WiFi, a Linux
                : device driver for use with Broadcom's BCM4311-, BCM4312-, BCM4313-,
                : BCM4321-, BCM4322-, BCM43142-, BCM43224-, BCM43225-, BCM43227-,
                : BCM43228-, BCM4331-, BCM4360 and -BCM4352- based hardware.
Vendor          : RPM Fusion

I have not encountered issues with updates. I usually steal ethernet from another system for upgrades, or hook up an old airport in bridge mode if the other system needs ethernet at the time.
I also have a USB wifi dongle to use when the other options fail me, but the iMac doesn’t have enough USB ports.

Interestingly enough I am doing basically the exact same thing for my 6yo daughter and need some help as well. I’m trying to install Fedora Silverblue 39 on a 2015 Macbook Air. I tried just doing the depmod -a on Silverblue as well and it complains about the read-only filesystem.

I had a USB-A to Ethernet connector somewhere in my house unless I threw it away, and I can’t find it so I am trying to simply install RPM Fusion non-free locally from an RPM. I dropped it in the Downloads folder and I go there in the terminal and run sudo rpm-ostree install rpmfusion-nonfree-release-39.noarch.rpm and have also tried sudo rpm-ostree install --disablerepo=* rpmfusion-nonfree-release-39.noarch.rpm but it always gives me the following error:

harper@fedora:~/Downloads1$ sudo rpm-ostree install --disablerepo=* rpmfusion-nonfree-release-39.noarch.rpm
Checking out tree 3f6c3c5... done
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora updates-archive
Updating metadata for 'fedora-cisco-openh264'... done
error: Updating rpm-md repo 'fedora-cisco-openh264': cannot update repo 'fedora-cisco-openh264': Cannot prepare internal mirrorlist: Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-39&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]; Last error: Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-39&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]

This is probably a basic RHCSA question but how do I stop the upgrade from trying to upgrade all the other packages? Is there a better way to do this? Sorry for the book, and if I’m hijacking the thread I can create a new one.

thanks guys,
thanks for your feedback!
i checked and seems i have right version of broadcom-wl (exactly the same as @gnwiii ).
At this point i think probably happened what @computersavvy has well described above ; indeed
if I remember correctly, i did an immediate reboot after installing the new kernel.
thanks again to all for your great support -