Fedora 38 Workstation Gnome Setup Welcome Window Is Not Clickable

After installing Fedora 38 Workstation (using the Fedora-Everything-netinst-x86_64-38-1.6.iso) I am presented with the “Welcome to Fedora LInux 38!” Gnome Setup window.

Strangely, the “Start Setup” button is not clickable. That blue button’s color shade does not change to a light blue when I hover the mouse over it like I’ve seen elsewhere. It is like that Setup window does not recognize the mouse cursor, at all. Yet, the Network/Volume/Power widget in the upper right corner interacts fine with the mouse.

Pressing Alt+Tab shows that the Setup window is the only one.

Some other information that may be relevant: this computer uses an integrated Nvidia GeForce 6150SE nForce 430 for video – but I have done nothing special; it is using the nouveau driver fresh from the install.

Killing any of these processes from tty2 just results in them immediately restarting:

965 /usr/libexec/gdm-wayland-session dbus-run-session -- gnome-session --autostart /usr/share/gdm/greeter/autostart  --session gnome-initial-setup
971 dbus-run-session -- gnome-session --autostart /usr/share/gdm/greeter/autostart --session gnome-initial-setup
973 /usr/libexec/gnome-session-binary --autostart /usr/share/gdm/greeter/autostart --session gnome-initial-setup

Any thoughts on how I can get past this?

Fedora 38 and the version of the nouveau drivers used seem to have problems with the older nvidia cards. I don’t see why that would affect the clickable areas of the screen though.

The listing on nvidia.com for drivers to support that GPU is version 304.137 so it is extremely out of date and cannot be supported by any driver newer than the nvidia 340xx drivers from rpmfusion.

It appears you are doing a new clean install, and others with similar issues when installing F38 have seemed to succeed with a new install of F37 then a system-upgrade to F38.

I suspect though, that the issues are only going to get worse since it seems even nouveau drivers and the newer kernels are no longer properly supporting those really old devices.

Thank you so much for the reply, @computersavvy . Yes, I am trying to support an old box, so maybe it is time to get a new one.
But it just seemed so odd that the mouse could click the Network/Volume/Power widget in the upper right corner, but not click the Setup window.
Any ideas on how I could just kill the Gnome Start window from the command line? Is there some kind of answer file I can provide it?

Once the initial setup is completed it seems a file is created as ~/.config/gnome-initial-setup-done with the content “yes”.
I would expect that if one were to create that file with that content then the setup would no longer pop up when logging in.

In GRUB, you can temporarily add nomodeset argument to the linux line, which will boot the system in a basic graphics mode. You can use it to perform necessary operations, like updating or installing closed nvidia drivers.

Thank you again, @computersavvy . That was a good suggestion, but alas it did not work.

When installing Fedora 38, I only enabled the root account. Although I created a /root/.config/gnome-initial-setup-done file containing the word “yes”, it had no affect. Searching for other ways, I found this page – Disable Gnome Initial Setup Screen - gnome-initial-setup – and performed the section on disabling it for all users. Still no luck.

Looking again at the processes:

# ps -lfp 1880 -p 1878 -p 1872 -p 1847 -p 826 --columns=999
4 S root         826       1  0  80   0 - 131372 do_sys 08:20 ?       00:00:00 /usr/sbin/gdm
4 S root        1847     826  0  80   0 - 114896 do_sys 08:24 ?       00:00:00 gdm-session-worker [pam/gdm-launch-environment]
4 S gnome-i+    1872    1847  0  80   0 - 112030 do_sys 08:24 tty1    00:00:00 /usr/libexec/gdm-wayland-session dbus-run-session -- gnome-session --autostart /usr/share/gdm/greeter/autostart  --session gnome-initial-setup
0 S gnome-i+    1878    1872  0  80   0 -  1249 do_wai 08:24 tty1     00:00:00 dbus-run-session -- gnome-session --autostart /usr/share/gdm/greeter/autostart --session gnome-initial-setup
0 S gnome-i+    1880    1878  0  80   0 - 228039 do_sys 08:24 tty1    00:00:00 /usr/libexec/gnome-session-binary --autostart /usr/share/gdm/greeter/autostart --session gnome-initial-setup

I saw the welcome window was being run by the gnome-initial-setup user. Seeing in /etc/passwd that that user’s home directory was /run/gnome-initial-setup, I again attempted the fix:

# echo "yes" >> /run/gnome-initial-setup/.config/gnome-initial-setup-done

# chown gnome-initial-setup: /run/gnome-initial-setup/.config/gnome-initial-setup-done

Still no luck!!! This welcome window just will NOT go away!

Thanks @kparal . I was hoping to not go to the proprietary drivers. I’ll keep your suggestion in mind if I cannot find a way to disable the welcome window.

You can “disable” the welcome window by completing the setup, which you should be able to do by booting in the safe graphics mode :slight_smile:

Alas, I forgot the users account is created during that setup process. Since the process has not been run the user account is not yet created so my suggestion does not work. :upside_down_face:

Thank you, @kparal ! Adding “nomodeset” option to the GRUB command booted the machine up into what you called “safe graphics mode” and allowed me to finally click that “Start Setup” button. You solved my problem; thank you again!

Glad that it worked. The nvidia on linux experience is becoming more and more painful each year :frowning_face: