Fedora 38 not finding secondary monitor HDMI

I upgraded in place to fedora 38. Computer recognizes that something is plugged in to the HDMI output port. But it is not recognizing it as a monitor.
Hardware works on windows and with live USB of f38.
I commented on a ‘dead’ thread of the same topic and was summarily shutdown by a gatekeeper with zero troubleshooting advice. [:Raspberries:]
What is step one in the debugging process? I’m guessing xrandr; but what flag? Session is Wayland, DE is Gnome with no extensions. Also lspci sees my Nvidia and Intel graphics in both current install and live usb.

I was that “gatekeeper” and that thread was related to problems with fedora 30 and 3 years old.

Thank you for opening a new thread for your current release and posting more info.

Please post the output of inxi -Fzxx so we can see the details of what the system sees.

Is this second monitor plugged directly into the system? or is it connected to a docking station?
If it is a docking station have you tried unplugging the docking station then plugging it back in?

What is the GPU?

Have you tried unplugging the monitor then rebooting and plugging it back in after the boot completes?

You do not tell us if this is a laptop or desktop so more info is needed. We are glad to assist with adequate information about your hardware and software.

Hey Jeff,
Thanks for the guidance on how to troubleshoot this. I had a chance to plug into the TV today and run inxi -Fzxx. Never heard of that command before; very handy.
It’s an Nvidia 1660 Ti card in a laptop. I tried every permutation of update, reboot, plug in and unplug etc.
I ran this on my current system as installed; and on the same system when booted from a Live USB Fedora 38 beta. The USB is running the nouveau driver and the external HDMI works. While the current system is having some trouble communicating with the Nvidia 1660 Ti. I will drop the nvidia-smi output below the inxi (long).

System as is w/ HDMI plugged in

*[kevin@fedora ~]$ inxi -Fzxx*
*  Kernel: 6.2.13-300.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc*
*    v: 2.39-9.fc38 Desktop: GNOME v: 44.1 tk: GTK v: 3.24.37 wm: gnome-shell*
*    dm: GDM Distro: Fedora release 38 (Thirty Eight)*
*  Type: Laptop System: Razer product: Blade 15 Base Model (Early 2020) -*
*    RZ09-0328 v: 5.04 serial: <superuser required> Chassis: type: 10*
*    serial: <superuser required>*
*  Mobo: Razer model: DA550 v: 4 serial: <superuser required> UEFI: Razer*
*    v: 01.06 date: 09/16/2020*
*  ID-1: BAT0 charge: 59.2 Wh (100.0%) condition: 59.2/65.0 Wh (91.1%)*
*    volts: 17.4 min: 15.4 model: Razer Blade serial: <filter> status: full*
*  Info: 6-core model: Intel Core i7-10750H bits: 64 type: MT MCP*
*    arch: Comet Lake rev: 2 cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB*
*  Speed (MHz): avg: 1850 high: 2600 min/max: 800/5000 cores: 1: 800 2: 2600*
*    3: 2600 4: 2600 5: 800 6: 2600 7: 800 8: 2600 9: 800 10: 800 11: 2600*
*    12: 2600 bogomips: 62399*
*  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx*
*  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Razer USA*
*    driver: i915 v: kernel arch: Gen-9.5 ports: active: eDP-1 empty: none*
*    bus-ID: 00:02.0 chip-ID: 8086:9bc4*
*  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Razer USA*
*    driver: N/A arch: Turing pcie: speed: 8 GT/s lanes: 16 bus-ID: 01:00.0*
*    chip-ID: 10de:2191*
*  Device-3: IMC Networks USB Camera type: USB driver: uvcvideo bus-ID: 1-7:2*
*    chip-ID: 13d3:56bd*
*  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.9*
*    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa*
*    dri: iris gpu: i915 display-ID: 0*
*  Monitor-1: eDP-1 model: LG Display 0x0625 res: 1920x1080 dpi: 142*
*    diag: 395mm (15.5")*
*  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel UHD Graphics (CML GT2)*
*    direct-render: Yes*
*  Device-1: Intel Comet Lake PCH cAVS vendor: Razer USA driver: snd_hda_intel*
*    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:06c8*
*  Device-2: NVIDIA TU116 High Definition Audio vendor: Razer USA*
*    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16*
*    bus-ID: 01:00.1 chip-ID: 10de:1aeb*
*  API: ALSA v: k6.2.13-300.fc38.x86_64 status: kernel-api*
*  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse*
*    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin*
*    4: pw-jack type: plugin*
*  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel*
*    bus-ID: 00:14.3 chip-ID: 8086:06f0*
*  IF: wlo1 state: up mac: <filter>*
*  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet*
*    vendor: Razer USA driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1*
*    port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168*
*  IF: enp2s0 state: down mac: <filter>*
*  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8*
*    bus-ID: 1-14:4 chip-ID: 8087:0026*
*  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends*
*  Local Storage: total: 1.14 TiB used: 156.53 GiB (13.4%)*
*  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB*
*    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 37.9 C*
*  ID-2: /dev/nvme1n1 vendor: Samsung model: MZVLB256HAHQ-00000*
*    size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 21.9 C*
*  ID-1: / size: 929.93 GiB used: 156.23 GiB (16.8%) fs: btrfs*
*    dev: /dev/nvme0n1p3*
*  ID-2: /boot size: 973.4 MiB used: 293.2 MiB (30.1%) fs: ext4*
*    dev: /dev/nvme0n1p2*
*  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat*
*    dev: /dev/nvme0n1p1*
*  ID-4: /home size: 929.93 GiB used: 156.23 GiB (16.8%) fs: btrfs*
*    dev: /dev/nvme0n1p3*
*  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100*
*    dev: /dev/zram0*
*  System Temperatures: cpu: 48.0 C pch: 47.0 C mobo: N/A*
*  Fan Speeds (RPM): N/A*
*  Processes: 347 Uptime: 4d 5h 28m Memory: 15.47 GiB used: 2.73 GiB (17.7%)*
*  Init: systemd v: 253 target: graphical (5) default: graphical Compilers:*
*  gcc: 13.0.1 Packages: pm: rpm pkgs: N/A note: see --rpm pm: flatpak pkgs: 11*
*  Shell: Bash v: 5.2.15 running-in: gnome-terminal inxi: 3.3.26*

Well that was fun. Here is something else I discovered.

*[kevin@fedora ~]$ nvidia-smi*
*NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.*

I suspect that my upgrade in place to f38 has left my graphics card in the wind. not looking forward to clean install and reconfigure everything.

New install is not usually needed.
what is the output of dmesg | grep secure
If that shows as disabled then we only need to figure out what the deal is with the driver.
Please post the output of dnf list installed '*nvidia*' but use the </> button on the toolbar so it is posted as preformatted text and retains the formatting seen on your screen`

[kevin@fedora ~]$ dmesg | grep secure
[    0.000000] secureboot: Secure boot disabled
[    0.017109] secureboot: Secure boot disabled

[kevin@fedora ~]$ dnf list installed '*nvidia*'
Installed Packages
kmod-nvidia-latest-dkms.x86_64                                                  3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local
nvidia-driver.x86_64                                                            3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local
nvidia-driver-NVML.x86_64                                                       3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local
nvidia-driver-cuda.x86_64                                                       3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local
nvidia-driver-cuda-libs.x86_64                                                  3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local
nvidia-driver-libs.x86_64                                                       3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local
nvidia-gpu-firmware.noarch                                                      20230404-149.fc38                                                   @updates                 
nvidia-kmod-common.noarch                                                       3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local
nvidia-libXNVCtrl.x86_64                                                        3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local
nvidia-persistenced.x86_64                                                      3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local
nvidia-settings.x86_64                                                          3:525.60.13-1.fc36                                                  @cuda-fedora36-12-0-local

So that is how the terminal style quotes are formatted. Thanks for the tip.

I noticed some weird stuff here last night before I read your reply. I was comparing the dnf search vs installed “nvidia” results. It looks like what I have installed that was working perfectly before the upgrade, is now unsupported.

I have backed up everything in Home, and re-made my f38 USB so it is current (not beta). I am confident that purging what I have, (525) and reinstalling what is in the stable repository (470) all will be well again.

But I am ready for potential disaster.

You have the drivers installed from the repo cuda-fedora36-12-0-local and have the older 525 driver and not the current 530.41.03 driver.

Many have noted problems with drivers from that repo and I always recommend using the rpmfusion repo to install the nvidia drivers. Very few have any problems with the drivers installed from rpmfusion, and those drivers are tweaked and tested for stability and function.

You have the GTX 1660 card so the latest drivers are the proper ones for you to use.

With just a few steps I can guide you to remove those older drivers, disable the cuda-fedora repo, and install the drivers from rpmfusion.

  1. dnf repolist will give you the list of currently enabled repos. Find the one in the first column for the cuda-fedora repo then use sudo dnf config-manager --disable 'cuda-fedora*' to disable it.
    Also verify that you have either the nvidia-nonfree or the nvidia-nonfree-nvidia-driver (or both) repo(s) listed. If not then follow the steps here (Configuration - RPM Fusion )to enable the rpmfusion repos.

  2. remove the currently installed drivers with sudo dnf remove '*nvidia*' --exclude nvidia-gpu-firmware (the firmware files are required and installed from fedora).

  3. Disable the remaining modular entry from the cuda-fedora repo
    sudo dnf module disable nvidia-driver

  4. install the drivers from rpmfusion.
    sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda

  5. Wait at least 5 minutes for the modules to be compiled and installed. Once complete you will see a response to the command dnf list installed 'kmod-nvidia*'

  6. Once you get a positive response to step 5 then reboot and the system should load the drivers newly installed from rpmfusion.

1 Like

Step 3 produces this error. I attempt to use the workaround suggested, but it also errors.

[kevin@fedora ~]$ sudo dnf module --disable nvidia-driver
--enable, --set-enabled and --disable, --set-disabled must be used with config-manager command.
[kevin@fedora ~]$ sudo dnf config-manager --disable nvidia-driver
Error: No matching repo to modify: nvidia-driver.

Perhaps steps 1 and 2 have already removed everything?

!!! But moving forward I cannot find this “530” driver set anywhere; except a .run file I can download from Nvivia. Where did you discover it? is it in a repo I do not have for some reason? Do I dare to execute Nvidia’s .run file? This has broken so many systems for me.

This system has been upgrading ‘in place’ for a while. Hence the issues with f36 repos.

No, do not use the nvidia.run file. Installing with the procedure given replaces it and eliminates the problems that come from installing directly from the nvidia.com package.

It is in the rpmfusion repo. The link in the second part of step 1 shows how to configure those repos. You should configure both the rpmfusion-free and rpmfusion-nonfree repos.

If you enable those repos and perform step 4 with no errors then the action in step 3 is not required. If there are modular conflict errors then perform step 3 as it is now and try step 4 again.

I had a typo in step 3 that has been corrected so using it as-is now should work.

Just in general terms.
When a sequence of steps is given to perform a task, and one step returns errors, then it is very likely that following steps also will fail (sometimes causing other problems). The rule-of-thumb is to NOT continue until the error is solved. The rule-of-thumb is also to complete each step fully before proceeding to the next step.

It finally worked; but it took many repetitions, and much exploration. I ensured every repo was ‘enabled’. I verified over and over that RPM fusion was good-to-go.
After step 4 finally worked, I re-enabled the nvidia driver, listed installed nvidia to verify, and ran…

$ sudo dnf install '*nvidia*530*'

This for the first time revealed the 530 series drivers. In all previous attempts 470 was the highest I could choose from.

Thank you Jeff V. for the help. I hope this can help others debug their systems if they find similar errors.

There should have been nothing extra installed at that point, and all the requisites shold have been met.

This may have caused you problems.
It probably installed the kmod-nvidia package from rpmfusion which can conflict with the kmod-nvidia package that is built by akmods explicitly for the running kernel. The kmod-nvidia package is not intended for use with fedora but (it seems) for centos and rhel.
This from the rpmfusion how-to

sudo dnf update -y # and reboot if you are not on the latest kernel
sudo dnf install akmod-nvidia # rhel/centos users can use kmod-nvidia instead
sudo dnf install xorg-x11-drv-nvidia-cuda #optional for cuda/nvdec/nvenc support

Please show the output of dnf list '*nvidia*'.

sure enough I have what appear to be 2 ‘kmods’ and 1 ‘akmod’ package. Everything I was able to do to test the functionality works as of now. But I know this sort of conflict is what leads to updates breaking a system.

$ dnf list installed '*nvidia*'
Installed Packages
akmod-nvidia.x86_64                       3:530.41.03-1.fc38  @rpmfusion-nonfree
kmod-nvidia.x86_64                        3:530.41.03-1.fc38  @rpmfusion-nonfree
kmod-nvidia-6.2.14-300.fc38.x86_64.x86_64 3:530.41.03-1.fc38  @@commandline     
nvidia-gpu-firmware.noarch                20230404-149.fc38   @updates          
nvidia-modprobe.x86_64                    3:530.41.03-1.fc38  @rpmfusion-nonfree
nvidia-persistenced.x86_64                3:530.41.03-1.fc38  @rpmfusion-nonfree
nvidia-settings.x86_64                    3:530.41.03-1.fc38  @rpmfusion-nonfree
nvidia-xconfig.x86_64                     3:530.41.03-1.fc38  @rpmfusion-nonfree
xorg-x11-drv-nvidia.x86_64                3:530.41.03-1.fc38  @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda.x86_64           3:530.41.03-1.fc38  @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda-libs.x86_64      3:530.41.03-1.fc38  @rpmfusion-nonfree
xorg-x11-drv-nvidia-devel.x86_64          3:530.41.03-1.fc38  @rpmfusion-nonfree
xorg-x11-drv-nvidia-kmodsrc.x86_64        3:530.41.03-1.fc38  @rpmfusion-nonfree
xorg-x11-drv-nvidia-libs.x86_64           3:530.41.03-1.fc38  @rpmfusion-nonfree
xorg-x11-drv-nvidia-power.x86_64          3:530.41.03-1.fc38  @rpmfusion-nonfree

I should be able to remove the first ‘kmod’ package without problems. kmod-nvidia-6.2.14-300.fc38.x86_64.x86_64 is a partner of the kernel itself. (If I am understanding this)?

After removing kmod-nvidia.x86_64 neither nvidia-smi nor nvcc --version work. But the nvidia settings application lists the number of cuda cores.

This was all so easy when I switched to fedora 35…

With what you showed there I would remove both kmod-nvidia packages.
dnf remove 'kmod-nvidia*'
Then remove all the other nvidia packages
dnf remove '*nvidia*' --exclude nvidia-gpu-firmware
When that is done install nothing except what this command pulls in
dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda

After waiting a few minutes and confirming the kmod-nvidia-6.2.14… package has been recreated (use dnf list installed kmod-nvidia*) then reboot. Things should now be fully functional

That finally cleaned it up. I am sure you are quite sick of me by now, but I do appreciate your help.
Both the nvidia settings app, and nvidia-smi work properly now.
I never understood before how easy it was to create that conflict. It is likely why I lost functionality of the discrete graphics after upgrading to f38.

I will refer to this in the future. And be more careful.

Glad to be of assistance.
It is not really clear that one can install akmod-nvidia or kmod-nvidia but not both. Those instructions could easily state that but do not.

This is why I am very careful to provide clear instructions that work for almost everyone.

8 posts were split to a new topic: Fedora 38 not finding secondary monitor with AMDGPU

This worked for me. Thanks Jeff.

6 posts were split to a new topic: Fedora 38 second monitor freezing

This is it! I made an account to just give you kudos!
I struggled with Nvidia a lot on Fedora and ALL the other “how-tos” were breaking my system and it was a huge mess…


It is not really clear that one can install akmod-nvidia or kmod-nvidia but not both. Those instructions could easily state that but do not.

Every issue I had when f38 dropped just happened again after f39. This thread guided me through fixing it again.
Thanks again
I don’t understand how I configured this system to make this mistake upon version upgrades. I plan to do a proper (non-lazy) backup and clean install eventually. f40?
Paradoxically I find my fedora experience to be so stable overall that I am not as wiling to wipe the system the way I used to on other distributions.

Possibly not really your problem. It may be related to see what is reported here with the workaround given. This problem only seems related to the full system upgrade between versions; especially if it has worked for some time but only reappeared when you did the version update…