Fedora 37 workstation, can't connect internet after first boot login

I’ve set static IPv4, but can’t connect internet after first boot login. After disconnect the wired network and connect the wired network with the Gnome extension, I can connect internet. Any suggestions?

I’ve tried DHCP, I can connect internet well. It’s weird. :joy:

Check if your issue is DNS related and if so then replace local DNS with a public one:

1 Like

I set DNS to from ali, but you are right, I tried your solution of enable DoT, the problem is gone. :bluethumb:

Why should enable DoT when set custom DNS?

This ensures DNS traffic is not intercepted and redirected by someone upstream for hijacking or content filtering, which could affect connectivity check.
If plain DNS works fine, DoT is not required and can be skipped relatively safely.

But I must enable DoT to connect internet, before install fedora 37 workstation, I set static IP and custom DNS on ubuntu or deepin, all work well, and there’s no need to enable DoT. Is there any different between fedora an ubuntu or deepin?

Apparently there’s some difference in the default resolver configuration or implementation.

Fedora uses systemd-resolved utilizing modern DNS features, and local resolvers sometimes don’t support it resulting in degraded functionality and compatibility problems.

Other distros may take different approaches and have their own fallback settings to mitigate local DNS issues, however I haven’t used those in years so I’m not sure of the specifics.