Fedora 37 - unable to use wifi

I upgraded to Fedora 37 two days ago; everything initially worked fine.

Now I am unable to use wifi. nmcli shows “sw disabled” for the wireless adapter.
Please can you advise on how to enable the software or any other steps.

Note. I had exactly the same problem on my backup laptop. Wifi was working under F37; it then stopped and nmcli showed “sw disabled”. But on this laptop, the problem was fixed by a reboot.

please have a look at

rfkill list 

also, does your laptop have a hard kill switch? Button combo or physical switch?

rfkill list shows:
Wireless LAN - soft blocked: yes; Hard blocked: no

The problem is on a desktop with a wireless USB adapter. So, no hard kill switch.

I tried
rfkill unblock wlan

rfkill list now shows:
Wireless LAN - soft blocked: no; Hard blocked: no

But still no wifi

1 Like

After reboot, wifi is now OK.
Thank you to augennauf for the pointer to the solution.

But it does lessen my faith in F37 if that is arbitrarily disabling wifi.

1 Like