Fedora 37 kernel 6.1 issue with lenovo dock

Did you do the actualization?

Thank you for the suggestion. I am sorry but do I miss something here or do you mean the Windows USB LAN driver that I need to update?
I booted up Windows and checked the system using the Levono vantage programm to ensure everything is still up-to-date. As the problem was not solved for my computer with the newest kernel upate, I am back to the old 6.0.18 kernel that runs without problem.

I would apreciare if you could point me to the update you meant and/or tell me what I am missing.

Sorry, I meant to check if the dock has the newest firmware. I changed the link to the overview.
It shows software from october 22

Yes, everything is up-to-date this also includes the docking station.

@mgrolinger, I saw your original post with the distorted screen picture, and the rainbow effect on the right hand side. I’ve been fighting the same issue, with totally different hardware!

HP Zbook15 laptop
HP Thunderbolt dock G2
dual AOC monitors connected to the dock’s DisplayPorts.

6.018 kernel works fine. Booting any of the 6.1 kernels I see the same distortion you are seeing.
I was thinking it might be related to nouveau vs NVIDIA driver since I’m using nouveau…eventually going to see if that makes a difference. Not hopeful.

If both drivers behave them same, then something more fundamental has changed about the 6.1 kernel and it’s interaction with the thunderbolt dock.

BG3

Hi @abgthr ,
interesting problem, indeed.
I am also using the nouveau driver since I have been to lazy to disable the secure-boot feature to be able to boot unsigned kernels with the NVIDIA driver.

# sudo lsmod | grep nouveau
nouveau              2703360  1
drm_ttm_helper         16384  1 nouveau
mxm_wmi                16384  1 nouveau
drm_display_helper    180224  2 i915,nouveau
ttm                    94208  3 drm_ttm_helper,i915,nouveau
wmi                    45056  5 intel_wmi_thunderbolt,wmi_bmof,think_lmi,mxm_wmi,nouveau
video                  65536  3 thinkpad_acpi,i915,nouveau

Or you could easily install the akmods package then follow the instructions in /usr/share/doc/akmods/README.secureboot and enable signing of the drivers. Then when the drivers are installed they would be automatically signed and easily load with secure boot enabled.

This would give you the best of both worlds. Secure boot plus the full features of the nvidia card, including harware acceleration of graphics.

1 Like

Hi everyone.
I am having the same problem with the Lenovo Universal Thunderbolt 4 dock (FW is up to date), connected to my Lenovo T15 G2.
On kernel 6.0 it worked great, but on 6.1 hotplugging was causing the external displays not to work anymore. Initially, they work after booting the system, but after you disconnect the dock and reconnect, the screens are detected, but they’re showing a “no signal” message.
It’s interesting to note that I have the exact same problem with PopOS on another Lenovo T15.

Yesterday, my Fedora updated the kernel to 6.1.18 and I noticed that hotplugging works again, but only if you boot the system without being connected to the dock. After boot, you can connect and reconnect as many times you want and for me it works :slight_smile:
Maybe this will mitigate the problem for you too, until they properly fix it.

I am just curious.

What happens when the Thunderbolt dock is connected to a type-c non-Thunderbolt port of your laptop?

@computersavvy Thank you for the idea. I will take a look into it, when I find some time. You are right, I’d like to have best of both worlds.

@slimdeluxe Thank you for your feedback. It is for sure worth a try. Usually, I had the opposite effect. If not connected by boot time the laptop and docking station behaved like aliens. :slight_smile:

@sampsonf a Lenovo P1 gen 3 has only two thunderbolt connectors and no non thunderbolt. There would be a possibility of a regular always on USB 3.2 gen 1 on the other side, but I am not quite sure if I want connect the dock via this port.

I’m back in business. Not because of the new kernel, but because I cried UNCLE and moved my external monitors off the thunderbolt dock. I didn’t really think NVIDIA was going to have any effect and with all the secureboot and simpledrm issues really didn’t have the time to invest in checking that.

Luckily I have one regular HDMI port plus two usb-C thunderbolt ports, so I have the port real estate to move my monitors to separate connections and still keep power control and everything else on the thunderbolt dock. The only downside is two extra connections to plug/unplug when going mobile.

Dual externals working great on the latest kernel with builtin nouveau driver. Maybe someday I’ll come back around and try the displayports on the dock again.

Solved for me: thank you @computersavvy ,I installed akmods and the NVIDIA driver. Now, I am running the 6.1.18-200 kernel without problems. Two displays are working: 1 HDMI and 1 DP connected without distortion.

1 Like

Thanks Michael! Good to know, and surprises me it’s a difference in the driver. Seemed like nouveau had finally stabilized for me, then this hits. I used to run the NVIDIA driver before F36. When I get some time I may make the switch back to NVIDIA too.

Since @mgrolinger had such good luck, I made a run at installing the NVIDIA driver over the weekend. Turns out I don’t have SecureBoot enabled so that was not a problem. Using kernel 6.1.18-100 and NVIDIA driver 525.89.02, my external monitors on the docking station are working again!

I had to add kernel boot parameter nvidia-drm.modeset=1 to get my externals to work right.

Would be interesting if you already tested this while it not was working with changed kernel. To see if not just this would have been the solution?

Just to see, I booted with nouveau and nouveau.modeset=1. Still the same distortion on the external monitors through the docking station. Reboot with NVIDIA driver active, all good.

Definitely the NVIDIA driver solved the problem.

1 Like

Interesting that you seemed to need that parameter. The install of the nvidia drivers from rpmfusion has always added that for me.

From /etc/default/grub I see this

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init"

All of which is added when installing akmod-nvidia from rpmfusion.

1 Like

I did it the hard way. :slight_smile:

Downloaded the driver direct from NVIDIA and ran the NVIDIA*.run to build and install the driver.

This is an example of why it is recommended to install the nvidia drivers from rpmfusion. The RPMs provided there are tweaked and adjusted to just work with fedora, while the drivers directly from nvidia may require the user to do the modifications that are already done by the developers at rpmfusion.

Also, when installing from rpmfusion the normal system updates of kernel and drivers are managed automatically with updates while drivers installed directly from nvidia must be manually recompiled with every kernel update.