Fedora 37 freezes on boot logo after setting up root password

Hello. Recently I’m following the Linux From Scratch book to learn something. I followed its suggestion to modify /etc/fstab to automatically mount my newly created partition on my usb device every time. My modification in /etc/fstab is as follows:

/dev/sdc1 /mnt/distro defaults 1 1
/dev/sdc3 /mnt/distro/boot defaults 1 1
/dev/sdc4 /mnt/distro/fat defaults 1 1

But after rebooting, my Fedora just won’t boot and enters Emergency Mode while it can’t since I haven’t set up a root password. Therefore I followed the Fedora docs (How to Reset the root Password :: Fedora Docs , which saying I need to create a root password manually since it’s not set on Fedora 28 or newer), chrooted under a Ubuntu LiveCD, set up a password for root using passwd root and commented /etc/fstab to disable my modifications:

# /dev/sdc1 /mnt/distro defaults 1 1
# /dev/sdc3 /mnt/distro/boot defaults 1 1
# /dev/sdc4 /mnt/distro/fat defaults 1 1

But after all this, my Fedora freezes after displaying the boot logo every time when I try to boot.

I don’t know why since everything leaves “unchanged” except for the root password. Is there anyway to fix this? Thanks in advance.

1 Like

When customizing /etc/fstab, it’s a good practice to use disk labels or UUIDs instead of disk paths/names and append the option nofail if the device might not be present.

You should also test the configuration with:

sudo mount -a

If the issue persists, try booting with SELinux disabled:


Huge thanks! I temporarily disabled selinux in grub and the system boots finely after autorelabelling.