Fedora 37 - Can't have wifi properly working - Realtek 8821CE

Hello everyone.
I’m new to Fedora. For a number of reasons I want to install it on my personal laptop and replace Linux Mint. Before deleting my current system I installed Fedora 37 on an external hdd so I can see how it works with my hardware, and everything worked fine and out of the box except one thing - wifi.
The problem is every 5 minutes or so wifi stops working, in the GUI it looks like everything is ok but it doesn’t work until i turn wifi off and on, which immediately fixes it. I have a Realtek 8821CE wireless adapter, and installed GitHub - tomaspinho/rtl8821ce driver (before installing the driver it worked the same way). The weird thing is that on Linux Mint I had 0 issues with wifi, having an older kernel. Pls help me since I really want to use Fedora but this problem stops me from installing it.

1 Like

It sounds like power management. Does modinfo -p rtl8821ce show an option to disable power management?


1 Like

Thanks a lot guys. It turns out i had installed the specific driver but was still using the generic driver that came pre installed, i just had to change that and now it works

Glad you were able to fix that.
If you were to post the details on what was done to not load the generic driver and instead load the one you created then other users with similar problem may be able to find the details on how you did the final steps for the fix.

Of Course. Remove the existing driver:

sudo modprobe -r rtw88_8821ce

Then I installed the driver, as explained on the README file of the repository.
Finally, to load the driver i just installed:

sudo modprobe 8821ce

That’s runtime configuration, but you likely also need persistent one:

sudo tee /etc/modprobe.d/rtl8821ce.conf << EOF > /dev/null
blacklist rtw88_8821ce
install rtw88_8821ce /bin/false
sudo tee /etc/modules-load.d/rtl8821ce.conf << EOF > /dev/null

(post deleted by author)

Tysm. I did that and a reboot and now it works flawlessly. It looks like nothing stops me now from installing Fedora on my laptop