Fedora 36 won't wake from sleep since updating to kernel 5.19

I was responding to @grgwmsm’s question about whether there were solutions from the journal post, not suggesting it was a wrong question to ask.

The issue was becoming too big a problem so I installed Debian 11 on the X1CG9. Interestingly, the problem just repeated on Debian after flawless wakes since installing several days ago. Debian is on 5.10 kernel. But don’t forget Debian woke 9/10 times so it seems this is telling me something about the source of the problem. I have Fedora 36 on a Yoga X13G2, so I’ll continue to troubleshoot on that.

Anybody know if these factors might be influencing the problem:

  1. I have the computer connected to a ThinkPad dock (ThinkPad Hybrid USB-C, Lenovo Part Number 40AF0135US). The dock has a wired mouse and ethernet cable going into it. A USB-C cable goes from the dock to the laptop delivering power, ethernet, and mouse.

  2. At night before I go to bed, I turn off the switch on the Panamax surge protector that the dock is plugged into because the dock and computer emit light even when in suspend and I want to control light when sleeping.

  3. Upon installing OS, I removed (uninstalled) power-profiles-daemon and installed tlp because tlp let’s me control battery charging (e.g., stop charging at 80% and start charging at 30% and I leave laptop on charging cable without worry about damaging battery).

Might any of the above items be affecting this failure to wake?

Is there a way to manage battery stop/start charging without installing tlp? Then I could test that out and see if removing tlp affects the problem at all.

Sounds like this issue is also showing up in Ubuntu. A couple people say they fixed it by disabling the Security Chip in BIOS.

I have the same issue with X1C9. I have tried to disable the Securty Chip in BIOS, but the result is the same. It just freezes when it “wakes up” from sleep.
And with 5.19. kernel, the LED on microphone (F4) doesn’t work anymore.
The power button (for turning it off) never worked…

Just my 2c

edit: I didn’t have anything to do yesterday evening, so upgraded to 37 beta. And now the wake/sleep works as expected.

This seems to me to be the same problems I’ve seen for the last 4-5 years only my problem is not entirely related to waking from sleep (however in the last year it seem to be). The original problem could happen while you were actively using the system. It would seem to lessen on some kernel releases and then come back again. Now on 5.19.9-100.fc35.x86_64 and the most recent failures to wake have also brought down my router where there appeared to be no internet or wifi connections to any other devices in the house. My system is a desktop. To restore my internet and wifi all I had to do was power down the desktop. My router is a Linksys WRT 3200ACM. Don’t know if this should be an entirely new thread but it does seem related.