Fedora 36 Nvidia kernel module is missing after upgrading from Fedora 35

After updating my install from Fedora 35 to Fedora 36 upon boot I am told the Nvidia kernel module is missing. no idea how to fix this as it just worked on Fedora 35. I am running a GTX 980 if that helps, though I think it is still supported by the current drivers. I don’t want to use Nouveau as I actually value gaming performance.

1 Like

Hi @stormfart , welcome to the forums.

Please see the introductory posts in the #start-here category if you’ve not had a chance yet.

Did you install the drivers from RPM Fusion? If so, please update your F36 installation and see if that helps. If it is fully up to date, try re-installing the Nvidia drivers. That should do it. It’s possible that the upgrade process didn’t result in the kernel modules being generated, which is why your system is falling back to nouveau. As the doc says, one needs to wait for a bit to let the kernel module finish building:


“Please remember to wait after the RPM transaction ends, until the kmod get built. This can take up to 5 minutes on some systems.”

well I just reinstalled the drivers and that worked.

1 Like