Fedora 36 Memory from 4Gb to 8Gb will not run. Boots, but goes into restart upon opening any program

After spending much time installing Fedora 36 beta, KDE, very nice buy the way! I thought adding an additional 4Gb of ram won’t hurt. Ram sticks were installed, the machine saw the increase and did not complain, but after booting into the system, KDE desktop came up fine, however when opening first “system monitor,” sent it straight to reboot. A second try, same deal, tried to open “web browser,” straight to restart. Is there a solution for this?

Try removing extra 4gb kit and try booting into system if everything
Works as intended then add that ram stick on another slot and dual channel is recommended and try to boot.

There are 2 things to be aware of when installing additional RAM.

  1. The new ram must be compatible with the older ram. Speed, size of the module, and other internal factors must match. Mismatched RAM will cause problems. I always buy matched ram when building or upgrading a PC.
  2. Most motherboards today use dual channel memory. It works single channel with only one DIMM installed, but when a second is installed it should be in the proper slot to work dual channel. Make certain the RAM is installed as instructed by the user manual.
1 Like


just so I understand, after trying the 1st 4gb stick say in slot A, and if it works ok, add the 2nd 4gb stick to slot B and see if it then works? By the way, this is a Dell Latitude E6510, i5 laptop.

1 Like

This is critical information. Laptops are build differently than desktops and usually have different slots (number and size).
This is the spec sheet from dell for that laptop.

Are the RAM chips identical? If not the failure is likely due to mismatched RAM.
If they are identical then it could easily be due to dirty contacts on the chip or socket. Contacts on the chip can usually be cleaned by rubbing with an eraser.

1 Like

Best is send both ram stick image we can see if both are same.
It is likely to be mismatch issue as you have said you have tried with 4gig kit one by one so kits are okey.

1 Like

I believe the issue is the new 8gb ram is PC3L and the old 4gb is PC3, which require different voltages 1.35V to 1.5V respectively, sooooooo it won’t run in the Dell E6510. No big deal as the new 8gb works in another laptop. Here is the photo, old on the left, new on the right! Thanks again for everyone’s help!

1 Like

From the markings on those it seems there are different timings on the chips and that certainly can cause problems. Your analysis is likely correct.