Fedora 36 KDE : keyboad layout bug with French Canadian Default

Hello ! First post here :slight_smile:
I have Fedora 36 KDE freshly installed, but for some reason , the dead key on the keyboard do not work (French Canadian layout, default variant). I tried all the variant and same problem. I tried on 2 different computers with different keyboards (all with Fedora 36 KDE freshly installed), same problem. So I cannot write the letter â, à, è, ô, etc. The non dead keys work though (e.g. é, É)
This is very basic stuff that works everywhere else and I am quite deceived, since otherwise I love Fedora KDE ! I will be forced to do distro hoping if I dont have a solution, since I need to be able to write French.
I have read elsewhere that by “exiting” the ibus icon (invisible / blank) in the system tray, this solve the problem. It does indeed , as far as I could see, but it seems to introduce other problems (e.g. on already opened applications where the keyboard does not work anymore afterward) and it anyway must be redone every time after reboot.
Please help. Thx !

  Kernel: 5.17.11-300.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17.11-300.fc36.x86_64 root=/dev/nvme0n1p4
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: TUF GAMING Z490-PLUS v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 2601
    date: 10/29/2021
  Info: model: Intel Core i7-10700F bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xF0
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 4708 high: 4796 min/max: 800/4800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4700 2: 4697 3: 4732
    4: 4704 5: 4699 6: 4702 7: 4705 8: 4700 9: 4699 10: 4700 11: 4796
    12: 4698 13: 4700 14: 4700 15: 4701 16: 4703 bogomips: 92796
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] vendor: ASUSTeK
    driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-3 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:7340
    class-ID: 0300
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.2
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu display-ID: 0
  Monitor-1: DP-3 res: 1920x1080 size: N/A modes: N/A
  OpenGL: renderer: AMD Radeon RX 5500 XT (navi14 LLVM 14.0.0 DRM 3.44
    v: 4.6 Mesa 22.0.3 direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:06c8 class-ID: 0403
  Device-2: AMD Navi 10 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1
    chip-ID: 1002:ab38 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.11-300.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes

I have a similar problem with French canadian default layout. The 3 keys with accent does’t work and I really need it. I’m on Fedora 37 KDE but the problem look the same.