Fedora 36 Cinnamon new install - chmod doesn't work

$ sudo chown user:user Data

isn’t working in Fedora 36 Cinnamon. No change in ownership of any kind occurs. I have a disk formatted as NTFS that I would like to access as user. I have created the mountpoint /home/user/Data, but have as of yet not added the disk to /etc/fstab.

The current output, that refuses to change is:

$ ls -ld Data
drwxrwxrwx. 1 root root 4096 May 20 10:22 Data

Hello @globetrotterdk ,
It’s been awhile since you’ve posted.
I am thinking this is related to an selinux permission issue for the mount point possibly, but you could try to add your user group to the mounted volume with the chgrp command recursively. After that, if the group gets added you should be able to claim ownership with chown, maybe. I wish I knew more to help with the selinux potential because this does seem like selinux is to blame for your problems.

Linux uses numbers, Windows UID’s for permissions, so unless you have a username mapping, you cannot do this on a NTFS disk. See the ntfs-3g manpage for details. Simply accessing all files on the disk as “user:user” is possible with the “uid=user,gid=user” mount option.


He he. Yes it has been awhile. I had serious technical problems with my computer for some time, that I haven’t been able to solve myself, plus evacuated from Ukraine, etc…

As there is nothing on the disk, I think that the easiest thing to do is to probably create a shared partition as per this post and this video. The thing is that the disk is 4 TB and I was originally thinking of sharing the whole disk between systems…

Sorry to see the raging war in Ukraine. It is criminal.
Why would you ask Unbuntu for Fedora Linux?
Also, what @hmmsjan said.

Absolutely a crime. I just searched for my issue and the links that I posted came up. It seemed relevant enough as many of us (Gnome, Cinnamon and Budgie users) use the Disks utility…