Fedora 35 videos refuse to playback

Hello world! Recently installed Fedora 35 for the first time and immediately faced an issue. It doesn’t matter where i open the videos, they just don’t work. On youtube there’s just infinite loading, default player just don’t playback, VLC plays the videos, but there’s no sound. Tried to install all the codecs i found throughout the web, but it didn’t help. Tried switching to X from Wayland, also didn’t help. Followed dosens of guides and no one helped.

Tried to somehow debug, but with my little knowledge the only thing i’ve got is these things down below.

This is what i got when opening YouTube main page

And this is what i got when tried to open the video

Hope those links are working because i can’t attach a propper picture due to the limitations of new users on this forum

The specs are:
Nvidia MX110
Intel Pentium Silver N5000

Would highly appreciate any help

All the codecs from throughout the web may not be helpful.

Did you follow that guide here? Installing plugins for playing movies and music :: Fedora Docs

Install rpmfusion repos (free and non-free) after that run ‘sudo dnf install ffmpeg ffmpeg-libs’ in terminal.That should be enough to run videos .One more think if you using firefox for your browser you should check Digital Rights Management (DRM) Content in setting and tick box

You might also have to check if pipewire and wireplumber are running correct.

I had same problem with youtube, long loading and never opening video.

Check in terminal:

systemctl --user status pipewire*
systemctl --user status wireplumber