Fedora 35 not working well after wakeup

When waking up Fedora 35 (Wayland and Gnome) after it has been at sleep, it happened the last days that the OS was really buggy and some programs crash (e.g. Firefox or Thunderbird) and the audio didn’t work.
When wanting to restart the computer, the process was taking a lot of time due to some audio procresses that didn’t want/took a lot of time to end.
I even go this message: systemd-shutdown[1]: Waiting for process: pipewire, wireplumber, alsactl
After a restart of system it works again, but this is very anoying as my system is now really instable, which wasn’t the case before!

For audio, may be you want to try with systemctl --user restart pipewire and systemctl --user restart wireplumber. Also may be you want to consider to upgrade your system. If I can recall correctly, there some update packages related to sound available.

I already did all the updates, and am on the latest versions.

These commands take so long thatI cancel them before they even finish…

Would you like to check and post the result of:

# For global service
systemctl status alsa-state

# For current user service
systemctl --user status pipewire
systemctl --user status wireplumber

May be we can start to find something from there.

● alsa-state.service - Manage Sound Card State (restore and store)
     Loaded: loaded (/usr/lib/systemd/system/alsa-state.service; static)
     Active: active (running) since Thu 2022-02-10 13:06:21 CET; 17min ago
   Main PID: 960 (alsactl)
      Tasks: 1 (limit: 23803)
     Memory: 448.0K
        CPU: 13ms
     CGroup: /system.slice/alsa-state.service
             └─960 /usr/sbin/alsactl -s -n 19 -c -E ALSA_CONFIG_PATH=/etc/alsa/alsactl.conf --initfile=/lib/alsa/init/00main rdaemon

févr. 10 13:06:21 localhost.localdomain systemd[1]: Started Manage Sound Card State (restore and store).
févr. 10 13:06:21 localhost.localdomain alsactl[960]: alsactl 1.2.6 daemon started

● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
     Active: active (running) since Thu 2022-02-10 13:23:07 CET; 1min 54s ago
TriggeredBy: ● pipewire.socket
   Main PID: 3860 (pipewire)
      Tasks: 2 (limit: 23803)
     Memory: 7.7M
        CPU: 181ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─3860 /usr/bin/pipewire

févr. 10 13:23:07 localhost.localdomain systemd[2472]: Started PipeWire Multimedia Service.

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-02-10 13:23:11 CET; 3min 54s ago
   Main PID: 3892 (wireplumber)
      Tasks: 4 (limit: 23803)
     Memory: 5.8M
        CPU: 358ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─3892 /usr/bin/wireplumber

févr. 10 13:23:11 localhost.localdomain systemd[2472]: Started Multimedia Service Session Manager.
févr. 10 13:23:11 localhost.localdomain wireplumber[3892]: Failed to set scheduler settings: Opération non permise
févr. 10 13:23:12 localhost.localdomain wireplumber[3892]: <WpPortalPermissionStorePlugin:0x555efa8e8ce0> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera

If I can remember correctly, I also have this message couple days ago and now gone after update. But nothing wrong with my system. My guess it should be ok. For comparison my current wireplumber version at 0.4.7-2.fc35. You could check it with dnf list installed | grep wireplumber.

The other user reported after uninstalling alsa-utils the problem gone. https://discussion.fedoraproject.org/t/i-broke-my-audio-with-the-last-update-no-sound-wireplumber-involved-and-others/71154

For above message, I search on the bugs reported on wireplumber, it’s only happen if we have sway session that use wlroots. There user reported can resolve it by edit /user/share/pipewire.conf and change:

api.v4l2.*      = v4l2/libspa-v4l2


#api.v4l2.*      = v4l2/libspa-v4l2

Then run systemctl --user restart pipewire and systemctl --user restart wireplumber.

I’m on for wireplumber

Well I don’t really want to moify anything in my systems…I expect it to work normally without any need for tweeking. Would alsa-utils cause such an issue? (by the way my problem is still hapenning)

Hi, this only for the first error message. I think no need to uninstall it since last time I have the error report, everything works normal.

For the second error message, there a way to only configure it for current user only (not as system wide) and easy to remove.

# Copy `/usr/share/pipewire/pipewire.conf` to `~/.config/pipewire/pipewire.conf`.
mkdir ~/.config/pipewire
cp /usr/share/pipewire/pipewire.conf  ~/.config/pipewire/

# Edit newly copied file
nano ~/.config/pipewire/pipewire.conf

# Inside the file, find part:
api.v4l2.*      = v4l2/libspa-v4l2

# Change it to:
#api.v4l2.*      = v4l2/libspa-v4l2

# Then save it with `ctrl + x`.

# Close all windows except the terminal (important), then run:
systemctl --user restart pipewire
systemctl --user restart wireplumber

If above not work and you want to go back to original setting:

# Delete local config we crated above:
rm ~/.config/pipewire/pipewire.conf
rm -rm ~/.config/pipewire

# Close all windows except the terminal (important), then run:
systemctl --user restart pipewire
systemctl --user restart wireplumber

Well is this causing the issue after the wakeup?

I’m not sure for that specific case. But if something wrong with wireplumber, any client that managed by wireplumber will run sluggish (music or video player, browser, or any audio video clients). That is why if we run either systemctl --user restart pipewire or systemctl --user restart wireplumber, it’s important (at least from my experiences) to close all windows except the terminal.

1 Like

Thanks a lot for taking the time to help me :heart:
On the wireplumber bug tracker someone has a similar issue than me, see here: Fedora 35 : wireplumber service does not respond (#186) · Issues · PipeWire / wireplumber · GitLab

1 Like

A patch is on the way for kernel 5.16.11 :+1:

I will wait for it to arrive on my computer, and if it solves the issue will mark the thread as resolved!