Fedora 35 Fresh Install Timeshift Only Live USB Mode Error

Yesterday i installed F35 and i downloaded Timeshift. But for some reason it’s in live usb mode, in the location setting there are no disks so i can’t backup the system.

1 Like

Welcome to ask.fedora !

Could you please give us more infos as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

The Timeshift package that you can install from the Fedora repository doesn’t work on Fedora Linux 35.


Upstream version is 21.09.1 (and it contains the required patches), while the one in the Fedora repository is still 20.03

So, until the Fedora package maintainer will not build the new version, you could use the package from this COPR repository: oprizal/timeshift-upstream Copr

Here are compiled newest timeshift from Github for temporary update until timeshift on the main Fedora repository get updated by the package maintener . This version intended to fix timeshift bugs on Fedora 35 Workstation.


There seems to be updates to Timeshift now.

As I am new to Fedora. How can I install this new version?
I already did sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-86afb128b6 but whend doing sudo dnf install timeshift it wants to install still the old version. Neither is Timeshift available from the gnome software gui.

sudo dnf install --enablerepo=updates-testing timeshift 

In case you have it installed already, just run

sudo dnf upgrade enablerepo=updates-testing timeshift
1 Like

Ah. So by default dnf picks only “main”(?) repos and I have to manually tell it to use some other?!

This is quite confusing as in the software gui there seem to be these repos available, too but this program just doesn´t seem to list all “programs” available, too. Reminds me of the “software” option in the manjaro gui package manager which shows only “normal programs” after ticking it and not packages like ffmpeg for example. Is there an option here, too? Did not find any so far.

Dnf by default uses all currently enabled repos. The updates-testing repo is disabled by default so when you want to use it you must explicitly enable it (each time) as noted above.