Fedora 35 freezes during or quickly after first login

Hi, I installed FC35 on Dell Latitude E7490 (touch screen) with 1T Kingston SSD as dual boot with Windows11. I installed W11 OS+apps and next I tried get working FC. Unfortunately I got random freeze rarely but it was working. Kate editor was complaining about missing export dependency so I forced system upgrade “yum upgrade”. 1.2GB packages downloaded and when upgrade process started upgrading it crashes to text mode and freezes. After reboot graphical prompt appears, I can enter password, desktop seems working, I can run an app and after a while it freezes (mouse cursor, buttons, keyboard - it just switches on backlight when a key is pressed, static screen content). I can only force power-off. I tried emergency mode, disable secure boot and no change. I saw that display blicked just before crash (graphic driver issue?) so I tried Ctrl+Alt+Fx to force logging in text mode prompt. In this case it surprisingly got frozen immediately when I started typing user name.

It looks as a kernel problem. Any idea how to overcome? Maybe somehow backport original packages even the system was not stable as well. But how when I cannot reliably login. I possible somehow avoid any graphical stuff when booting, i.e. just text mode console messages ?

Another idea is to get ready virtual machine wsl2 in W11 and boot from there as it should be hopefully somehow more stable but still experiencing with wsl and btrfs mounting.


Hi, what Fedora Linux flavor you installed? Workstation (Gnome), KDE, Mate, etc.? Most of the time, all have different steps to find the solution.

These day, Fedora Linux using dnf which have enhanced capability instead of yum.

It is standard Workstation installation with gnome desktop. I made no extra low level changes (just I mounted ntfs extra disk partitions in fstab and it was working). Probably wayland is running, i tried to force xorg at password screen but AFAIR only black screen appeared.

yum vs. dnf: I know :wink:

:thinking: If these spec are correct, may be you want to read this other distro wiki to find common problems with intel graphics. There also mentioned about Intel UHD 620.