Fedora 35 - Dual Boot with Windows 10 - "network cable unplugged" in Windows only

I have a custom PC running Windows and recently decided to repurpose an older SSD to install Fedora 35 using the Workstation Live iso. The installation went fine and I can boot both OSes. However, after booting into Linux, Windows seems to be unable to use the wired network adapter built into my motherboard. Observing the network adapters in Windows, this adapter just reported “network cable unplugged”.

In researching the symptom, I have come across some older posts:

The second link above seemed to be related as toggling the WoL settings in Windows got the network card working again one time, but booting into Linux again has broken the network adapter in Windows again. I have tried repeatedly toggling these settings, booting and fully shutting down from each OS (pulled the power cable and switched the PSU), and pulling the CMOS battery, but none have made a difference in Windows.

If I boot into Fedora the wired network adapter works fine.

Does anyone have any ideas?

Edit: I thought I would mention a few other things I have tried:

  • Disabled the “Allow the computer to turn of this device…” setting in the network adapter’s properties
  • Checked the BIOS for anything related to WoL, but there are no settings
  • netsh interface ip reset and netsh winsock reset

SInce you mention wake up on lan option available on your card, on the same tab there should be option about “Allow the computer to turn off the device to save energy”, try to disable it. If you could find anything related to energi saving on your LAN card there (maybe on advance tab), disable it. Then try to reboot.

Thank you for responding. That was one setting I did try toggling but forgot to mention in my OP.

Use fedora 35 only don’t use windows(if you can) and your problem solved
As linux opensource it is better
And if you need windows for some specific application then you can easily create a windows vm with kvm qemu or virtualbox. Untill it solves the issue.

For solving this issue can you give the output of inxi -Fzx

1 Like

Have you disabled Windows’ Fast Startup thing? It might skip re-initializing some hardware.

1 Like

Thanks for responding. I was not aware of this setting in Windows.

I was actually able to get the network adapter working in Windows again, but I did not document each step I took up to that point. I was then able to reproduce the issue, so I am now putting together some notes on what pattern causes it.

After additional testing, the fix ended up being needed to shutdown from Fedora and pull the power cables before turning the computer back on. I am interested to know what the underlying cause is between the two operating systems.

1 Like