Fedora 35 + Dell XPS 15 + external monitor won't show desktop after login


I have installed Fedora 35 for the first time (previously have been using Ubuntu and Windows) because of the issues other OS had with WiFi and BT on my Dell XPS 15 9500 (i9 10885h).
In general, I have managed to set up everything in a way that satisfies me, there are some minor issues that I can live with but the following issue is very troublesome for me.

I have the Dell mentioned above + Dell WD19TBS dock + 2 x 27" Display Port Monitors, internal laptop display is disabled when using the dock. On the other hand, the same thing also happens when plugging an HDMI monitor (single) into the laptop.
I prefer to work when the laptop lid is closed. When starting or rebooting the machine it works fine until it gets to log in. The login screen appears correctly, I can enter the password and when it’s done and normally gets to the desktop, suddenly monitors get dark, and after a while laptop gets to a state similar to suspension - nothing is visible, fans turn off, etc. Sometimes I am able to turn it on again by hitting the button on the Dell Dock, but it is rather random. Usually, it wakes up, then goes to sleep again. Once it is in this state it rarerly helps to open the lid again. More usually I need to do a hard shutdown by holding the laptop’s power button for a long while. This is very very annoying. This does not happen when the lid is opened - but for my reasons, I prefer to have it closed.

Any idea on what can that be and how to solve it?

The second issue is connected with the first. When the state of “suspension” happens and I hard-shutdown it, the WiFi card, and Bluetooth - Killer AX500-DBS gen unavailable - no Wifi and BT is present on the system. I have to boot Windows - then the BT and Wifi are still not available. I have to shut down the PC properly, boot windows then it appears, and I can get back to Fedora. Extremely annoying, but happened also on Ubuntu (kernel 5.13). On fedora, it happens only when the case above occurs, so I can live with that for now.

I will be grateful for any tips. I am not very proficient with Linux details - I am a developer that finds Linux a great development platform.

I got a similar issue on my HP Folio - 2000. The strange thing is the screen seemed to flicker whenever there was an overlay (like the dark overlay when you view the workspace). In my case, the display flickered, then slowly faded until it went off when the display went dim while showing the WiFi Connections dialog. I managed to do a fresh install but at some point during the boot process, the external display goes off and says there’s no signal while the laptop display seems to be on (main display is broken, but you can see some areas of the screen.


  1. Power on PC normally or with nomodeset flag / Live USB / Rescue Mode.

  2. External display loses signal halfway through the boot process.

  3. Error shown was (in summary): Light Display Manager failed to load due to /dev/zram0 failing to mount.

Fix 1 (didn’t work):
Fresh install after deleting the Fedora partition from Windows using PartitionMagic.

Fix 2 (partially worked):
I managed to get the external monitor to display by pressing the display button on the keyboard until the display showed (strangest thing ever, seems the display drivers for anything but the inbuilt display aren’t being loaded correctly at this point, or probably being loaded after logon?).

The main issue is I have to guess when the system has reached the user login screen, hope that I’m actually in the input field, enter the password then manually press the screen button until the desktop shows on the external screen.