Fedora 35 Beta - malcontent


Just configured a VM to play with fedora 35. As usual, I tried to remove software I don’t intend to use.

when trying to remove the new parental control app throught the software center, I get an error message and the app stays. So I tried to use:

sudo dnf remove malcontent

It wont let me. Seems it sees gnome-shell as to also be removed.

[xxx@xxxx ~]$ sudo dnf remove malcontent
[sudo] password for xxx: 
 Problem: The operation would result in removing the following protected packages: gnome-shell
(try to add '--skip-broken' to skip uninstallable packages)
[xxx@xxxxx ~]$ sudo dnf remove malcontent --skip-broken
 Problem: The operation would result in removing the following protected packages: gnome-shell

Any Idea why?

How can the new parental control app be removed?

Thanks in advance!

It’s required by gnome-control-centre, which is required by gnome-shell:

rpm -q --requires gnome-control-center | grep -i malcon

See also:


It’s now part of the Gnome desktop set of packages, so these packages will require it and so on.
Is there a reason you want to remove it? Much better to leave it and just not use it?

To remove it, you’ll need to use rpm, and sort of force it’s removal. Something like:

rpm --erase malcontent\* --nodeps

The --nodeps bit tells rpm not to remove deps.

This is really not recommended, and later when you update to new versions of gnome-shell etc., it’s likely that malcontent will be reinstalled as part of the transaction.

PS: on F35 here and at the moment I can’t figure out how to use malcontent. No “parental control” app here. I’ll have to go read their docs etc.

Edit: found it—in users, in settings, one can enable parental controls and all that.


Thanks for the clarification.

I just see it as good practice to remove any unused software.

If malcontent is not removable shouldn’t it be placed with the other non-removable apps in the software center?

1 Like

It should. Not sure how protected packages are managed in gnome-software, though. (malcontent itself is not protected, but it’ll remove other protected tools like gnome-shell.)

1 Like