Fedora 35 and Icecat Browser

I have a some issue with Fedora 35 and Icecat Browser. I use Fedora on Wayland but the same issue is on X11.

When I want to launch Icecat Browser from menu the Icecat wouldn’t start. So I was trying to start it from terminal and when I try to start I get a information:

/usr/bin/icecat: line 72: fg: no task control 
Memory protection violation (memory dump)

I start figuring what is on the 72 line indicated location and this looks that:

## Enable Wayland backend by default?   
if %{wayland_default} && ! [ $MOZ_DISABLE_WAYLAND ]; then
  if [ "$XDG_CURRENT_DESKTOP" == "GNOME" ]; then


Does anyone know what could cause this issue?

@kubatron Welcome to ask :fedora: please take a minute to have a look at https://discussion.fedoraproject.org/t/welcome-to-ask-fedora-please-read-me-first/7

This is a bug thanks for pointing it out.

Does the same crash happen if you run as a new user?
Are you running any additional extensions have you tried running with those disabled?

Great , one of these two bugs was gone after last icecat update BUT…the last question from you about it is the same error of memory protection when I switch to other user account - answer is YES and NOT.

So, I try in virtualbox in one of the Fedora KDE, XFE and GNOME version and in normal user, not root but user to work daily, the error is still showing, but I try to switch to “root” and on the VM and in my daily Fedora KDE I saw these information.

On my daily user account where I paste bugs in early posts, one of those is still there:

Memory protection violation (memory dump)

And let me be clear these information are only when I switch to “root” and when I create new NORMAL account without explicitly “admin/root” permissions, only using useradd.

restorecon: SELinux: Could not get canonical path for /home/kupa/.mozilla/icecat/* restorecon: No such file or directory.

(icecat:11199): dconf-CRITICAL **: 08:31:12.383: unable to create directory '/run/user/1000/dconf': Permission denied.  dconf will not work properly.

And when this information in CLI is showing, the ICECAT is working because it is start and I can use, but in CLI, I see 10x these information, but when I switch back to my daily user account the information about memory corruption is back and icecat is doesn’t work, even if I try start “icecat”, “icecat-x11” or switch to wayland and use “icecat-wayland”, I try install these 3-y versions.

So if I think right, the problem is somewhere with SELinux. Furthermore, I have normal Firefox, Librewolf on desktop.