Fedora 34 on Mini PC Celeron N3450

Got this great little mini PC from Awow that uses Intel Celeron N3450. Linux Mint boots from USB flash drive and runs live okay, and installs okay. I can’t get any other current Linux distro to do the same. What I really want is Fedora 34. I’ve tried the Server and the IoT versions of 34. This is x86_64, so I’m using the downloads for that architecture. I’ve got Secure Boot disabled. I tried legacy mode and UEFI mode from BIOS/Settings, neither will install. I can always get the boot menu for any of the distros, but as soon as I choose “start setup” or “boot live Linux” kind of option, then blank screen and nothing ever seems to happen after that. So any tips or tricks, hints, suggestions, are greatly appreciated.

Welcome to the community.

First check that firmware is up to date. Second you might have to use an other Spin. I’m using the Mate Spin an are very happy with it. XFCE is also a light DE. Please try and give feedback.

Which version? But you know that Linux Mint and other Ubuntu based Distros are fare behind with the Kernel Version? So compare it with Fedora is not very representative.

I’ll try some different spins of Fedora. I may try Rocky Linux as well. I just need to get something close to RHEL8 for the work I’m doing. I wasn’t comparing Linux distros, I merely mention that the only one I’ve been able to install was Linux Mint (Ubuntu based), that’s all. I’m in no way trying to compare and say one is better or worse. Just that Linux Mint did install, and about 10 other distros I tried did not, including the one I want/need which is Fedora.

1 Like

If you are looking for something close to RHEL then you might try Centos Stream. IIUC it is somewhere between Fedora and RHEL.

The official release of Fedora 35 is due out in about 2 weeks and if I understand correctly it will have kernel 5.14.

So I found some interesting results. I created a Ventoy USB flash drive with a bunch of Linux distros on it to try out several. Just to be clear, when I try to boot a live distro or install a distro, here’s what happens when it fails: black screen, nothing happens, no DHCP, nothing. I tried editing the grub boot
and removing “quiet” and adding “inst.sshd” and “inst.vnc” to try and get DHCP and network activity as some additional sign of progress, and perhaps try for success. But many failed.
To reiterate some of my settings.
Model || Awow AK34 PC Box with Intel Celeron N3450
BIOS: || American Megatrends v1.07 x64 (build 12/09/2020 19:42:45)
EC Version || 1.07
BIOS/UEFI boot mode || UEFI
Secure Boot || disabled

My results so far…
RHEL 7.9 || success
Rocky Linux 8.4 || success
Linux Mint 20 || success
RHEL 8.4 || failure as described
Fedora 32,33,34 Server, Workstation, NetInst, CoreOS, IoT, XFCE spin || failure as described
Ubuntu 20.04 || failure as described
Ubuntu 21.04 || failure as described
ElementaryOS v6 || failure as described
Manjaro xfce 20.1.2 || failure as described
Tails amd64 4.21 || failure as described
OpenSUSE Leap 15.2 DVD, Gnome Live || failure as described
SystemRescueCD || failure as described

Wierd that some work, most don’t. Especially that mix of RHEL, Fedora and RockyLinux success and failures!

Strange yes … did you also note the kernel versions ?
Fedora uses 5.11.22 upwards