Fedora (34) keeps booting into tty

So I pressed Shift on startup because I needed to boot into tty. I did the usual (added 3 to the end of the appropriate string) and pressed F10; did what I had to do and rebooted. Upon reboot, it automatically booted into tty mode again, so I rebooted and removed the 3 at the end of the string, logged in, and rebooted again to see if it stuck… again, it booted into tty :roll_eyes:

I even tried dracut to see if I could get the changes to stick, but to no avail. On other distros I’ve used, adding the 3 isn’t a persitent change (i.e. rebooting boots the system into GUI mode).

Could someone help me? I’ve tried googling, but I can’t find anything.

Please post your kernel boot parameters by

cat /proc/cmdline

1 Like
BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.12.9-300.fc34.x86_64 root=UUID=acd8a867-31be-40a4-90ba-3d2e186d813a ro rootflags=subvol=root rhgb quiet 3

So you still have the 3 as boot parameters.

You can remove it by

'sudo grubby --update-kernel=ALL --remove-args=“3”.


Thanks! I’ll try as soon as I get home :grin:


Worked flawlessly! Many thanks!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.