Fedora 34 KDE - display goes offline at login screen


My machine is a desktop with an rtx2060 and this morning I ran the biweekly update (everything) which pulled new nvidia drivers from rpm-fusion, amongst other things.

Everything works after, including the new nvidia power handling…except the login screen, which is shown for a split second before the monitor says “no signal” and goes offline. If I type my login password (at the blank screen) and hit enter X loads the desktop and that’s where I’m writing from now.

Nothing obvious in the system journal. Any advice? : )

NVIDIA 470.74, 5.13.19-200

Seems to have less to do with nvidia and more with the KDE theme I was employing (Breeze dark):

okt 02 19:06:35 feds sddm-greeter[9576]: Loading file:///usr/share/sddm/themes/01-breeze-fedora/Main.qml...
okt 02 19:06:35 feds sddm-greeter[9576]: QObject: Cannot create children for a parent that is in a different thread.
(Parent is QGuiApplication(0x7fffc6ced880), parent's thread is QThread(0x55db66834a80), current thread is QThread(0x55db66910eb0)

Though even after having changed from breeze to something else in every window under appearance: global theme the sddm still goes looking for the same file with the same result.


Does KDE use Wayland or Xorg?

Double check and if you are using Wayland, switch to Xorg, because Wayland does not work well with NVIDIA.

Your session can use Xorg while your login screen still may use Wayland. This may cause your problems on the login screen.

In that case you would have to set the default to Xorg.

But after all, I’m not so familiar with KDE.
Someone else may help better with that.

Hi, thanks for your reply. I’m not sure how to check what the login-screen uses; it shows the choice for the session. I switched to X soon after installation because Wayland didn’t work overly well with the nvidia driver, which maybe you meant to say.

(I would have switched from Nvidia some time ago but if you want a card that can game some well good luck Chuck)

Bildschirmfoto von 2021-10-03 20-46-46

A default KDE install says it uses Wayland.

So now we have to figure out how to disable wayland and enable xorg.


Mine is set to X11 and has been from almost the start. Wayland/X11 is chosen on the login screen. Maybe it is shown with wayland, I don’t see wayland mentioned in the journal when booting though.

There are several older threads around the internet regarding a blank screen and “cannot create children” : sddm produces black screen, "Cannot create children", autologin works / Applications & Desktop Environments / Arch Linux Forums 553996 – x11-misc/sddm fails to start on boot with KDE , I’ll look into things suggested in those (even if they’re older) tomorrow after work, if I have any energy left.

Just to update I tried adding the sddm user to the video group and separately to delay the sddm-greeter start by 20 secs as mentioned in 553996 – x11-misc/sddm fails to start on boot with KDE , neither thing made a difference for the login screen.

this seems to work, for what it is worth:
sddm-greeter --test-mode --theme /usr/share/sddm/themes/01-breeze-fedora/ - the login greeter screen appears and stays, the monitor doesn’t go into standby and no error messages about children.

Edit. It would be interesting to see whether the issue persists with the Nouveau driver.

Hello everyone again, now it seems like the nvidia driver again : ) Did

dnf remove xorg-x11-drv-nvidia\*

and rebooted with nouveau and the sddm-greeter stayed visible. Journalctl still says

sddm-greeter[2676]: QObject: Cannot create children for a parent that is in a different thread.

so that wasn’t directly tied to the issue at thand.


Note: The Wayland windowing system is not yet fully supported: Wayland sessions are listed, but SDDM runs on X11. SDDM 0.20 will introduce full Wayland support.[1] .

sddm master is 0.19, I don’t know what Fedora 34 uses.

ssdm-greeter --version 

replies “sddm-greeter”

Edit. And reinstalled the nvidia drivers with

sudo dnf install akmod-nvidia
sudo dnf install xorg-x11-drv-nvidia-cuda      --for opencl in darktable
sudo dnf install xorg-x11-drv-nvidia-power    --for the nvidia power/suspend method, opencl stays available after machine has been suspended with opencl running

and rebooted and the sddm-greeter functions normally (screen doesn’t go offline anymore).

So the issue had to do with my machine’s nvidia drivers, reinstalling them as per the rpm-fusion instructions seems to have done the trick

1 Like