Fedora 34 in VMWare Fusion 10, MacOS Mojave

Hi Team

A decade ago I ran Fedora up thru 12 on a PC, and then on a MacBook Pro running VMWare.
With the advent of Big Sur, I am seriously looking to move back to Fedora.
DL’d Fedora 34 this AM, and installed it in VMware Fusion 10.1.1 on my 2017 MBP running Mojave 10.14.5.
Installed OK, but when I started to set up an account, the installation failed with a “Something went wrong; contact a SysAdmin” error. Same thing if I boot the “recovery”. The “Live” version seems to be OK, tho.
A search here didn’t turn up anything useful.
Does anyone know if this will work? Is there any way to get a log of what is failing, or perhaps boot into a lower run-level? (Does that even apply?) Any other thoughts?
And can anyone tell me where to find a system requirements for the newer Fedora? All I could find was “2GB/20GB”. I think I have an old HP (WInXP) laptop in a box somewhere; probably from about 2000. 2GB ram and 40GB drive IIRC. Likely to work, or no?
TIA! Steve

Almost all the logs are in the systemd journal these days.

The command:

journalctl -b

will show you all the logs since your most recent boot. You can skip to the end and then scroll back from there.

You can get a TTY at any time by pressing ctrl+alt+f3 if your graphical session is broken.

Hi Dalto, All

Installing an OS as a virtual machine always adds a layer of uncertainty. I was totally unable to get the hot-key sequence to open a terminal window. Maybe because Fedora startup was running a “Setup” script, or maybe because of the “F” keys being virtual on the touchbar of this Mac? Whatever, it wouldn’t happen. So I went thru several restarts getting screen captures of the “Setup” windows, attached. Generally, at the “about” screen, the system would hang, and display the error window.
However, either because I typed faster, or who knows what, I was finally able to get past the “setup”, and now Fedora seems to be running as intended as a virtual machine.I have re-booted it several times, and even “Yummed” in a couple of apps successfully. Gotta love a self-healing OS :slight_smile:
Anyway, once it started, I opened a terminal window to look at the ~2500-line log. There were numerous warnings, but the only line saying “Critical” reported: “CRITICAL: Unable to create a DBus proxy for Gno”; “Gnome”, I’m guessing, the rest of the line was off-screen in the terminal window. And this was a log for the successful boot, so that may be irrelevant anyway.
Here are the captures, in order. Whatever was troubling it appeared to be a hard fault; the OS was unresponsive, and I had to shut it down and restart from VMware.
Anyway, now the fun begins; I get to systematically go thru my daily routines to see if Fedora will work for me. The only real concern I have is to determine if I can make Gimp run my large format Epson printers. Unless things have dramatically changed with the new Fedora, everything else should be a no-brainer.
Thanks for your input. Steve, aka george_t_mule (Who is currently glaring at me wanting his dinner, guess I’d better get going with the hay cart.) Bye! S.

P.S.: Forum software barfed on my attachments; sez “Only One”. Here, then, is the error window:

While yum is still available, just a heads up that Fedora moved to dnf quite a long time ago. Might be worth learning how it works at this point.

Compared to 2009 when Fedora 12 was released, the state of the Linux desktop is substantially better. Many more applications, better hardware support, usability improvements, etc, etc

I feel old.

1 Like

Hi Dalto, All

Wow, Fedora 34 is slick; I’m very impressed. Thanks, and Kudos to all of the developers who contributed to getting it to this point. And that dnf package manager is way beyond expectations, thanks for the tip.
So I found a nice clean Lenovo Thinkpad “Yoga 260” on eBay at a very reasonable price, and will be replacing the OEM WinTen OS with Fedora as soon as I get it, and verify that everything is working as intended.
Just out of curiosity, is there anything in the current Linux that is analogous to the MacOS “Time Machine”? Reason being, I will want to upgrade the 250 GB SSD in the Thinkpad to a 1TB module. In the past on Linux, such a life-changing event would require one to start fresh, which means duplicating howevermuch work you have put into the system to that point.
I did find a procedure to accomplish this via command-line, but it’s far more complex than just grabbing a Time machine image, and it would mean that I would also have to purchase an external M.2 drive enclosure. I already have a Terabyte external SSD.
Failing that, I will probably wait until I get the drive upgrade installed before installing Fedora.

Thanks Again, Steve

If you just want to backup your home drive which is where most of your configuration data is stored there are lots of options including something like backintime.

If you want to try to image your whole root drive, you could use something like timeshift. However, I personally, haven’t tried to take a timeshift image from one machine to another.

Hi Dalto

Looks like timeshift will do just what I need.
I would be surprised if timeshift could copy a system from one machine to another, unless they contained the same exact hardware. Probably the only reason it works with Time Machine is that Apple uses a strictly defined hardware set throughout.
But in my application, it will be the same laptop, just a different SSD.
Thanks Again! Steve

1 Like