Fedora 34 has gone faulty

Fedora 34 has gone faulty. My processor overheated as the fan was obstructed by wires that had moved. It failed. I put the ssd in another machine with similar processor. It had 4 operating systems on all worked fine except the Fedora 34 that was active in the failure.

Now the Fedora boots OK but Thunderbird starts for a minute then disappears and I cannot restore it. Firefox starts but the restore button does not do anything.

The upgrade comes up but nothing happens except saying cache.

I am at a loss to see what I can do to restore it.

I am thinking of trying something from my other Linux Lite using the Fedora Volume but have no idea what to try first.

Do you think I should try a Timeshift restore?

Anyone, with ideas please?

Was it doing an upgrade when the PC failed? (if yes, run sudo dnf distro-sync)

Is the SSD ok? Is the file system ok?

Did that which allowed the Thunderbird to work but the Firefox would still not work.

Then I did Timeshift for one 2 months ago but still the Firefox would not work.

Start Firefox from command line and see what it says.

You can also create a new Firefox profile and check if that starts up.

You can also create a new user and start Firefox to check whether something in your profile isn’t quite right.

It sounds like the OOM Killer. Does the replacement system have enough RAM?

1 Like

Thanks for that it only had one strip where the other had two now it appears to be fixed except firefox is hugging the side and is minimised. It has no buttons to maximise.

Thanks for your help.

Found the Firefox buttons on the extreme right. It now is working OK.