Fedora 34 boot stuck at start job is running for /dev/mapper/fedora_localhost--live-swap

After update kernel to 5.11.11-300 boot stuck at start job is running for /dev/mapper/fedora_localhost--live-swap and start job is running for /dev/mapper/fedora_localhost--live-root

5.11.10-300 works fine.

I use 34 beta release

Please add this feedback to


along with some basic description of your hardware and filesystem layout.

I’m hitting the same issue after upgrade from f33 to f34 but also with 5.11.10-300.fc34 and other remaining kernels on my system - 5.11.11-200.fc33 and 5.11.10-200.f33. I’m only able to boot to rescue mode with 5.3.7-301.fc31 :confused:

Looks like it’s caused by dracut-0.53, see:


The only fix atm is downgrade to dracut-0.51 and reinstall the kernel.

edit - the following steps worked for me.

Boot with a working kernel (any f33 one should work)
Apply the fix from here: fix(network-manager): no default deps for nm-run.service · dracutdevs/dracut@ba4bcf5 · GitHub
The full filepath is /usr/lib/dracut/modules.d/35network-manager/nm-run.service

Then run the commands:

sudo dnf remove *5.11.11-300*
sudo dnf update

I can confirm that this solution works

Thanks @rl

1 Like

Just tried to upgrade 33 to 34 after reading an article about v34 just being released.

After issuing a sudo dnf system-upgrade reboot the system finally booted to the alternating “start job is running for /dev/mapper/fedora-swap/-root”.

Does someone have a tip for me as to how to boot to a prior kernel without boot menu?

Hold down shift while booting to get the boot menu.

The latest version if dracut from the fedora repos fixes this, correct?

It was the same for me. I could only access the rescue mode. But @rl 's solution works as well via the rescue mode. I installed manually dracut 0.53-2 also, but I am not sure it was necessary. After adding the DefaultDependencies=no line and regenerating the initramfs (dracut --force /boot/initramfs-5.11.11-300.fc34.x86_64.img 5.11.11-300.fc34.x86_64), it worked.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.