(Fedora 34) Blue Yeti microphone plays back through its headphone port; how to turn off?

Hello, I am a new user of Fedora 34 on my desktop (and of Linux in general) and am very happy to be joining the community.

I use a Blue Yeti USB microphone as my both my primary audio input and output device, with headphones connected to the mic’s aux output. I’ve noticed that I can faintly hear the mic’s input playing back through my headphones at all times when using Fedora (for example, when I speak). I would like to disable this playback, but cannot find how, and so any advice would be appreciated.

Some things I’ve noticed about this behavior:

  • Using the physical mute switch on the Blue Yeti makes the playback stop.
  • Changing the output volume in the OS changes the volume of the playback, up to the point where muting the output volume stops the playback.
  • Changing the input volume in the OS does not change the volume of the playback.
  • I can still hear the playback even when I switch input devices (specifically, to my webcam’s mic).
  • When I switch output devices to some speakers I have connected to my computer, I don’t hear the playback through those speakers… put if I put on the headphones I still do!

Some of these observations would make me believe this is a hardware feature of the mic itself; yet, the Blue Yeti doesn’t have any sort of direct monitoring as far as I know. Besides, I don’t suffer this playback at all when I use Windows 10 on this same machine.


If it helps, here are some screenshots of my Sound settings panel:

Another screenshot since I am a new user that cannot embed more than one image at a time:

Typically I set both input and output to Yeti Stereo Microphone (not the S/PDIF option–I’ve tried it on that anyways and got the same results).

1 Like

I’m a little late, but this should do the job:

  1. Open alsamixer in Terminal
  2. Press F6 (Select sound card) → Select Yeti Stereo Microphone
  3. Turn down the Mic property [left/right arrow keys] to 0/-30 dB gain [up/down arrow keys]. (Not the capture one if this option exists)

Made an account just to thank you for this! Was worried I’d need to install Blues crappy windows software and jerryrig it to get it to turn off. Many many thanks!

Thank you! I’ve seen people recommend alsamixer but they never included the F6 step, which is what finally solved this more me!