Fedora 34 Audio Power Saving (Pops/Crackles)

Good day to you all, I’m new to the world of Fedora and just getting used to how everything is set up. One thing I really need to figure out how to fix, is how to stop a ‘pop’ or ‘crackle’ just before any kind of audio plays.

From the research I’ve done, I’ve narrowed it down to being related to power saving in some form or another - I have s

lspci output
0000:00:1f.3 Multimedia audio controller: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller (rev 20)

tlp-stat -s output
/etc/tlp.conf L0276: SOUND_POWER_SAVE_ON_AC=“0”
/etc/tlp.conf L0277: SOUND_POWER_SAVE_ON_BAT=“0”
/etc/tlp.conf L0283: SOUND_POWER_SAVE_CONTROLLER=“N”

snd_hda_intel power_save is set to 0 also

Can you think of anything else that might be causing it that I can check? It seems to be a couple of seconds after audio stops that it pops or crackles again

1 Like

So, I am having the same issue. Has there been a fix for this?

I found a solution.

The solution was creating a line in the /etc/modprobe.d/alsa-base.conf file (even though that file did not exist):

options snd-hda-intel power_save=0 power_save_controller=N

And then running the following command as root with a reboot for final solution:

dracut -f
1 Like