Fedora 33 won't boot after install. System keeps restarting

I just installed Fedora 33 using a live USB while deleting the Windows 10 partition I had. After installation, Fedora didn’t boot. Lenovo splash screen flashes for less than a second and says “system bootloader not found”. Then it keeps restarting infinitely.

  • I tired booting into live CD, used efibootmgr and deleted “Windows Boot Manager”, “Fedora”, “Fedora” (Not sure why I had two Fedora entries. probably because my last install of Fedora dual booting Windows 10 wasn’t removed), deleted my SSD partitions again (using Gnome Disks), and installed Fedora for a second time. still same issues as before…

  • I also came across an old thread on Lenovo forums saying that it could be due to me using a docking station!!! I didn’t think that made any sense (specially since I installed Fedora 33 last month as a dual boot with Windows 10 and always docked without any issues). Anyways, I tried pulling the dock. Still no difference.

  • Secure boot is off.

  • Every install was done using default settings and automatic partitioning except I turned on disk encryption. Though I did try an install WITHOUT encryption and same issues …

Right now I’m booting into the Live CD and as you can see below, efibootmgr didn’t remove the entries I deleted before! Anyways, I don’t even understand efibootmgr that much (just followed an online guide) but I can’t boot into Fedora.

How can I do a fresh/clean install of Fedora on my SSD deleting everything and fixing my EFI boot ?

I’m on Lenovo ThinkPad T460s and my SSD is using a GPT

Here’s the output of efibootmgr:

[liveuser@localhost-live ~]$ efibootmgr
BootCurrent: 001B
Timeout: 0 seconds
BootOrder: 0000,001B,0017,0018,0019,001A,001C,0001
Boot0000* Fedora
Boot0001  Windows Boot Manager
Boot0010  Setup
Boot0011  Boot Menu
Boot0012  Diagnostic Splash Screen
Boot0013  Lenovo Diagnostics
Boot0014  Startup Interrupt Menu
Boot0015  Rescue and Recovery
Boot0016  MEBx Hot Key
Boot0017* USB CD
Boot0018* USB FDD
Boot0019  NVMe0
Boot001A* ATA HDD0
Boot001B* USB HDD
Boot001C* PCI LAN
Boot001E* IDER BOOT Floppy
Boot001F* ATA HDD
Boot0020* ATAPI CD

Edit: Removed unnecessary preface

1 Like

If you no longer need dual boot, then just wipe the disk entirely.
In addition, upgrade and reset the BIOS/EFI firmware and reset the EFI boot settings specifically.
It should work with secure boot enabled and Intel RST disabled.

1 Like

disk was wiped entirely as mentioned in OP.
bios is already on latest firmware. What do you mean by “reset the EFI boot settings specifically” ?

It should work with secure boot enabled and Intel RST disabled.

I’ll try

Since you want this to be a clean install without windows I would suggest you first, from the live USB, run parted on the disk and create a new clean gpt partition table. That will wipe out the existing windows garbage remaining on the drive.

Then reboot the USB, making certain that when you select it to boot in bios that you pick the UEFI version to boot.

Now you should be able to select the drive and use the automatic partitioning install. Remember that doing a clean auto install on 33 will use BTRFS for everything except /boot and /boot/efi. If you want something else you will have to use the custom install.


What’s “parted”?

I use “Disks” to delete all windows partitions before installing Fedor. Didn’t that do the same thing?

You still have Windows leftovers and probably other garbage boot entries such as these:

Deleting partitions does not recreate the partition table.

1 Like

Going to the command line and using gdisk or parted allows you to create a new partition table. The disks tool does not give you quite the same low level control.

1 Like

I see. Would you mind helping me with the commands? I don’t understand partitioning on a low level

It should be the same as the following:

GNOME Disks > Select disk > Drive Options > Format Disk… > Partitioning > No partitioning (Empty) > Format…

1 Like

Thanks. I just remembered I already did something similar to this except last time I chose GPT instead of empty. Anyways, done! Efibootmgr is still showing same entries

Or from the cli,
sudo gdisk /dev/sdX
where sdX is the drive you are working with.

1 Like

There should be some menu in the BIOS/EFI to clean up or reset the boot entries.
It looks like this for me:

> sudo efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,2003,2001,2002
Boot0000* Fedora
Boot0001* EFI Network 0 for IPv4
Boot0002* EFI Network 0 for IPv6
Boot2001* EFI USB Device
Boot2003* EFI Network
1 Like

You can use efibootmgr to delete those old nvram entries and clean it up. Man efibootmgr

efibootmgr -B <bootnumber>
will delete the entry

1 Like

I used that before and tried deleting them last time but the entries came back in the next boot

Then maybe it needs to be done in bios

1 Like

The entries vgaetera just posted have nothing to do with windows. Those are default boot options for that bios except for boot0000 which is the entry he last booted from.

1 Like

You’re right! The option is so damn hidden too. But It’s done. Garbage disposed!

P.S. Fedora entey was NOT for the usb. It’s gone now

1 Like

Can I install Fedora now?

1 Like

should be able to.


Fingers crossed. Thank you both. I’ll get back to you shortly when it’s done

1 Like