Fedora 33 on Dell XPS 13 9310 - cannot use Qualcomm Killer Wi-Fi 6 AX500-DBS

I just got a brand new Dell XPS 13 9310 and tried to install Fedora in a Dual Boot configuration. That went well, except that Fedora doesn’t see the wireless network interface…

The card is a Qualcomm Killer Wi-Fi 6 AX500-DBS, which, I believe, is supposed to be supported by the ath11k driver. Unfortunately, although it seems this driver is part of the kernel sources, it seems it is not compiled by default for Fedora…

grep ATH11 /boot/config-5.8.15*

Returns nothing.

Output of lspci -v:

0000:55:00.0 Unassigned class [ff00]: Qualcomm Device 1101
        Subsystem: Bigfoot Networks, Inc. Device a501

Can I somehow find the appropriate drivers, or am I stuck with Windows 10 for a long time?


Thanks. I read that bugzilla issue as well, but when I read “This should be supported by the ath11k driver”, I took “this” to refer to “AX500”.

So naturally, I hopped on over to Rawhide (5.10.0-rc3) - no ath11k driver included. Same thing for the 5.9 kernel from fedora-testing.

It seems the module is simply not compiled when building the Fedora kernels. That may well be because the whole thing is not considered stable yet.

But if “This” refers to the AX1650, yeah, then I’m likely to be out of luck for the foreseeable future.

1 Like

We’ve just received our shipment of the 9310 as well. This came as a pretty big suprise (the AX500-DBS), we’d been using 9300 for a little while now which seem to have come with the AX1650. Dell’s webpage for the 9310 lists the AX1650 card… we totally didn’t catch this before our order shipped (we got a lot of these, all are intended to be Silverblue machines).

I’d love to know if this card would be getting inclusion into the kernel anytime soon, right now though I’m asking Dell if they can do an exchange. It’s frustrating that these AX500-DBS cards are showing up in machines that specifically call out the AX1650.


None of the Fedora kernels (testing, rawhide) include the ath11k driver. In the end, I found:

Which describes using a kernel branch to build the ath11k support. The branch that is mentioned, is based on 5.9.0, so I thought I’d try it with a newer kernel:

Using the f33 branch, I get a 5.9.8 kernel.

To enable the ath11k driver you need to turn on CONFIG_COMPILE_TEST and the relevant CONFIG_ATH11K variables in the kernel configuration:


After building the new local kernel and installing it, I have a ath11k driver that I can modprobe, but that’s it. It still doesn’t recognise my AX500. No kernel messages that indicate anything.

BTW, the instructions in the Ubuntu on XPS15 link regarding the firmware blobs (copying them to /lib/firmware) is not correct, at least not for the paths given, so I had to improvise a bit. Still not sure if that is the cause of the non-functioning, but then at least I’d have expected an error message in dmesg.

1 Like

I have an XPS 13 2020 that works fine. It was a windows machine, but I wiped that and installed Fedora. Here’s what inxi shows for my network. Wifi works well. A different card than you have?

  Device-1: Intel Wi-Fi 6 AX201 vendor: Rivet Networks driver: iwlwifi 
  v: kernel port: 3000 bus ID: 0000:00:14.3 
  IF: wlp0s20f3 state: up mac: <filter> 
  IF-ID-1: virbr0 state: down mac: <filter> 
  IF-ID-2: virbr0-nic state: down mac: <filter> 

Does this help any?

Thanks, yeah that is yet another card (Intel), and I believe, yet another (slightly older) XPS 13 build. The 9130 is the latest (just out), and comes with the Qualcomm chip. I managed to use the latest Rawhide (5.10.0-0.rc4) which manages to connect to my AP (yay!), but after putting it to sleep for a while, it lost the whole card; cannot even rmmod ath11k :grimacing:


Note that the 5.10 kernels have ath11k from rc2 onwards. I tested with rc6, where the WiFi does not survive a suspend/resume cycle (even if it’s s2idle). The 5.11 rc kernel (rawhide) has stable WiFi though.


I just tried on rawhide, which is now on 5.12.0-0.rc0. Everything works fine even after suspend/resume.


Indeed. It started working in the 5.11 releases, although I wonder if you managed to get through a reboot/shutdown without a hang.

In my case, there’s a crash in the mhi module when the ath11k_pci module is unloaded. At that point, reboot or shutdown will hang indefinitely.

From what I can gather, there is a two-line fix in drivers/bus/mhi/core/init.c that will fix this: kernel/git/gregkh/char-misc.git - Char/Misc drivers development tree

I will try to build a recent F33 kernel with that patch applied and report back.

I’ve performed several shutdown/resume cycles in Fedora rawhide (5.12.0) . I just did another cycle and there are no anomalies in the log. I’ve been running for days with no issues at all. When Fedora 23 beta comes out I’ll probably give that a try.

Fedora 34, not 23! :slight_smile:

1 Like

The 5.12.0 rc1 kernel works, indeed (rc0 was still crashing).

I also built a 5.11.2 kernel with the patch applied, and that works as well.

Will try the kernel from the 5.11 Fedora test week to see how that holds up.

I Have a XPS 9310 2 -1 and this is Network controller.

00:14.3 Network controller: Intel Corporation Wi-Fi 6 AX201 (rev 20)
Subsystem: Rivet Networks Device 1651
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at 60531dc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [c8] Power Management version 3
Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [40] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [80] MSI-X: Enable+ Count=16 Masked-
Capabilities: [100] Latency Tolerance Reporting
Capabilities: [164] Vendor Specific Information: ID=0010 Rev=0 Len=014 <?>
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

I see you have an Intel WiFi controller, which should be supported without issue (since kernel 5.2).

This thread was specifically about Qualcomm’s AX500-DBS (which is working in recent 5.12 rc kernels).