Fedora 33: intermittent network issue with RPMFusion and COPR repositories


As the title suggest, I have that problem with my fedora currently. I cant even install rpm fusion for non free apps without the terminal failing, and after when trying to install any other app, it hangs.

In software center, I cannot even update my repositories; I get an infinite loop.

There has to be something wrong with this OS; how can right after installation, such problems occur? I’ve tried Solus, Pop Os, Manjaro, Ubuntu and none of them have had even the slightest issue of what I am currently facing.

Is there a quick solution to this? Fedora is mentally exhausting.


It seems a network issue.
Maybe you hit an unfortunate mirror?

1 Like

me too. Something to do with thermald? My i3 dell laptop seems to be running/stuck @400 MHz. Can’t yet find a way to go faster. cpufreq/power utils not longer avail? Something disabling intel-p state?
Never a dull moment.

Please open a new issue @notandor, these two are not necessarily connected.

@freezeaim: while I understand the annoyance, your negative title makes the topic sound like a rant rather than a request for help. which tends to deter people from offering to help. I’ve updated the topic now.


Is this the only issue you are seeing? Your topic suggested that the system was generally laggy but this is very likely just a network/mirror issue as @alciregi suggests.

Are you seeing similar issues when installing from the Fedora repositories? Are you able to access websites correctly using the browser?

1 Like

Hi @freezeaim, could you please send me the outputs of the following two commands?

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor


cat /proc/sys/vm/swappiness

Then maybe I can help you with making Fedora fast :wink:

Yeah, I know. I got a bit frustrated; sorry. Anyways, after some hours, everything seems to be working. I can now somehow update my repositories and enable rpm fusion without any lag. And the only problem *was really the rpm fusion and the software catalog. The catalog seemed to go to an infinite loop when trying to search for anything, while the terminal couldn’t install anything due to rpm fusion again; causing the terminal to hang.


Here are the outputs:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

cat /proc/sys/vm/swappiness


That’s good to hear. You were just hitting a mirror that was either out of sync or just slower temporarily.

Gnome-software was “hanging” because it was also trying to update repository metadata.
DNF (and your terminal) weren’t hanging—they were waiting for the repository metadata too. DNF would eventually time-out here.

1 Like

Alright. Unfortunately, it seems to be happening again. Here’s a picture if it helps any.


Check this out @freezeaim.

This should help you.

Totally disconnected topic here. I could wait for you to create a topic for it or you can take a look at this.

By the way, this is the first time after a long while that you are posting here. Welcome back to Fedora! :smile:

Right, so, now it isn’t RPMFusion, it is COPR. This tells us that it is not an issue with an RPMFusion mirror, but something more general that’s related to your networking.

Can you please run a speedtest to show us your bandwidth etc.? Are you experiencing issues while browsing the web: are pages slow to load?

1 Like

It is impossible to be the network. Chromium browser is quick and snappy, and when I can download, I get speeds up to 10-12 MB/s

As you can see, the speeds aren’t the best, but they work.

Did you just term the 99.95 Mbps speed to be not good enough?

*Anger intensifies

Haha, indeed I did! Okay okay, it is pretty good.

Here’s what’s happening, according to the terminal:

Copr repo for PyCharm owned by phracek 0.0 B/s | 0 B 07:27
Errors during downloading metadata for repository ‘phracek-PyCharm’:

How do I solve this?

1 Like

Well, the COPR is certainly there and alive and there hasn’t been any announcement about COPR having infra/network issues, so it’s something to do with your setup:



Anyone else seeing a slow responses from COPR?

Well, due to COPR, my Software Catalog also gets slow… But that’s about it. After COPR update times out, the command that I would be running would be working without any problems.

For the time being, just disable these repositories.

We need to be slightly pedantic here to be able to diagnose the issue: it’s not “because of COPR”. It’s because for some reason, your connectivity to COPR (as was for RPMFusion which magically fixed itself) is poor. Now we need to diagnose why this is. It could be anything from a slow DNS resolver or server to an issue with your ISP, or another slow mirror (although I’m not sure if COPR uses mirrors).

I can’t think of a way to diagnose this off the top of my head—will have to think about it a bit. Others, any ideas?

Also, to confirm: your system isn’t laggy in general usage, right? It’s only this particular issue? It’d help to update to topic title to make it more specific. A generally laggy system implies performance degradation—which we’re not seeing here.

I don’t know about the ISP being the problem. How come this never occured when I used another Linux distribution?

No, there is not general lag. The terminal only seems to stay stuck when updating RPM Fusion (Yep, happened again) and COPR

I have tried reinstalling the system, to no avail. What seems to be the problem? I have never suffered this from other distro’s, or even Windows for that matter.

Not sure yet tbh. The other distributions use different mirrors, infrastructure/IPs for example, so that’s already quite a difference.

OK. So to be specific, the issue is that interaction with certain repositories, RPMFusion/COPR, is slow on your configuration.

Let’s also note this here: it isn’t the terminal hanging, that’s DNF waiting for the repository data. You can open another terminal tab or window to use the terminal if you need to.

OK, you need to slow down and try to understand what is causing the problem. A reinstall only helps if there was something wrong with your installation, and there’s no evidence to suggest so. If it’s a networking related issue, reinstalling will not magically fix it.

1 Like

At first I did think something was wrong with my installation due to not being able to boot into my USB the first time, resulting in a blank black screen.

And what I mean by terminal getting stuck is that dnf is waiting for RPM Fusion data, like you suggested, not that it is actually stuck and I have to terminate the process. This also causes Software catalog to go into almost an endless loop.

It seems to me that Fedora is not usable, atleast in my case. The best option may be to switch to a more, functioning distribution, as there isn’t any reasonable cause to this, unless you have something in mind.

This is geting incredibly frustrating, again. I can’t even install anything due to dnf waiting for RPM fusion…

Fedora 33 openh264 (From Cisco) - x86_64 1.6 kB/s | 2.5 kB 00:01
Fedora Modular 33 - x86_64 4.8 MB/s | 3.3 MB 00:00
Fedora Modular 33 - x86_64 - Updates 1.5 MB/s | 785 kB 00:00
Fedora 33 - x86_64 - Updates 39 kB/s | 9.3 MB 04:06
Fedora 33 - x86_64 8.7 MB/s | 72 MB 00:08
google-chrome 49 kB/s | 3.6 kB 00:00
RPM Fusion for Fedora 33 - Free - Updates 97 kB/s | 43 kB 00:00
RPM Fusion for Fedora 33 - Free 1.1 MB/s | 897 kB 00:00
RPM Fusion for Fedora 33 - Nonfree - NVIDIA Dri 7.5 kB/s | 8.3 kB 00:01
RPM Fusion for Fedora 33 - Nonfree - Steam 7.3 B/s | 1.7 kB 04:05
RPM Fusion for Fedora 33 - Nonfree - Updates 810 B/s | 1.2 kB 00:01
RPM Fusion for Fedor100% [====================] 9.0 B/s | 70 kB 00:00 ETA
Errors during downloading metadata for repository ‘rpmfusion-nonfree’:

This is how it looks like after a few minutes of doing a dnf install command…