Fedora 33 freezes frequently and randomly

arrrggghhh, I now see you wrote it in your first post.

mea culpa

I’m glad that I’m not the only one with this problem. Several times my entire computer has randomly freezed.

Also I have another problem, when I block my screen and the screen goes to sleep mode it never wakes again and it forces me to shutdown my computer. To get away with this problem I have to disable auto turn off my screen. The problem doesn’t appear when the computer goes to suspend mode only when my screen does.

I’m using:

  • CPU: Ryzen 5 1600X
  • GPU :AMD RX 5600 XT
  • RAM: 16 GB
  • SSD: Samsung EVO 860.

The only changes that I’ve done to the desktop are some gnome extensions:

  • Arcmenu
  • Dash to Panel
  • Tray icons: reloaded
  • User themes.
1 Like

As mentioned above, deactivate them and then switch them selective on. That you can find out if they make troubles or not.

Sorry I forgot to mention that this happen even before loging into my user account. Anyways I tried disabling gnome extensions and the problem still persist.

Thanks for reading.

I would like to add for anyone reading this, CTRL+ALT+F3 is a virtual terminal. When you say it ‘opens a terminal’, most people will think it’s that little terminal program that opens up in a window. A virtual terminal (VT) will confuse people who are new to linux. It opens a full screen terminal, which will ask for a login and password and can be frustrating when you’ve never seen this terminal before.

Usually CTRL+ALT+F1 or F7 will get you back to the graphical desktop. I haven’t used a VT in a long time so I’m not sure if F1 or F7 is correct for Fedora 33.

1 Like

This happens to my sons machine, appears to be random nothing in the journal. Unable to access a virtual terminal, ping the machine or ssh in.
Updated the bios and nvme firmware this weekend and observed same thing Tuesday afternoon.

Fedora 33 default gnome, all of the power save options are off.

GIGABYTE GA-AX370-Gaming (rev1.0)
AMD ryzen 5 1500
Samsung 960 evo
AMD rx580

Hoping that How to use kdump to debug kernel crashes - Fedora Project Wiki can provide some more data but haven’t gotten around to setting it up.

CitaI would like to add for anyone reading this, CTRL+ALT+F3 is a virtual terminal. When you say it ‘opens a terminal’, most people will think it’s that little terminal program that opens up in a window. A virtual terminal (VT) will confuse people who are new to linux. It opens a full screen terminal, which will ask for a login and password and can be frustrating when you’ve never seen this terminal before.

Doesn’t work neither, not imput of any kind work when this happen. Maybe this has to do with Wayland being the default graphical interface but I have to say that this also happen when I login with the x.org session.

I don’t know if this is the best place to report this, but when I shutdown my computer from Fedora 33 at the end when the computer supposedly be off, the monitor start doing a funny flickering of colors (wach the video) I know is not a hardware issue because when I do it from Windows 10, this doesn’t happen. It’s very funny and first time that this happen to me with a GNU/Linux distro.

I have to add, if I’ve being listening music in Fedora 33 before turn off my computer the weirdest thing happens. watch the video.

I also experience the hang like described here. I have been chasing the issue for many months already. The issue started when I upgraded to FC33 (I am conservative on upgrades because of such surprises, I upgraded from FC28). My hangs are happening when the display gets into screen saving mode / off. The hang has always happened when I am away from my computer. Only thing that works is to force power off and then start again. And the same: no error logs- just blank dead system without a trace. I have not tried to log in over ethernet with ssh. I am using XFCE and GDM. So, it appears I need to play with the Gnome and KDE services that it does start, or the screensaver applications e.t.c.

1 Like

Is it completely locked up or is it just xfce4-session? Can you switch to another virtual terminal by pressing Ctrl+Alt+F3? (try Ctrl+Alt+F4 or an even higher number if F3 doesn’t work).

It has been looking completely dead, no ctrl+ alt combinations work.

I disabled now the Gnome and KDE extensions, lets see if I see this lockup once again.

I have not tested if the ethernet allows me to ssh in, otherwise the mouse, keyboard and screen are nonresponsive.

I think when it is that “unresponsive”, it is almost certainly a problem with the kernel. The solution is typically to use an older kernel. Unfortunately, If you’ve done several updates since the “last known good” kernel was installed, it might be difficult to download and install the last working version from koji.

Sometimes the problem can be worked around temporarily by disabling a particular kernel feature. For example, if you are having problems with power management, you can disable that feature by adding noacpi to the list of kernel command line arguments. Another example that I personally encountered recently required adding iommu=soft to the list of kernel arguments to get the OS to load at all.

Beware that there are often trade offs to setting kernel parameters to non-default values. Completely disabling ACPI, for example, will prevent the system from being able to automatically power-off when you perform a soft shutdown (you will have to press the physical unit’s power button after all the services have stopped). Also, performance may be impacted. Disabling ACPI will also prevent hyper-threading from working on Intel processors (though in that case there is a comprimise – acpi=ht – that might allow hyper-threading to work while still disabling most of ACPI).

Thank you.

One of my doubts has been that the issue is somehow related to gnome screensaver… and from there maybe something related to ACPI. It has never been locked when XScreensaver is active. I think that my message is so messy at the moment that the only takeaway is that I have been seeing this kind of hang. I was investigating if my SSD is failing, since I have seen similar hang to happen in the past and the reason was that the SSD did lock up on write. The SSD was too much filled and many failing sectors were on it. The SSD is OK at this time.

Ah ha! Sounds like a similar scenario to me.

Before the beginning of 2021, I was bad at upgrades, and had Fedora 27. Then I had a login loop error lock me out.
So for a few months I did switch to the more commonly used Ubuntu 20.04, which was working well, except that it would randomly freeze whenever about once a week. But then it was beginning to get more intolerable and I switched back to Fedora 34, which I was always more comfortable with. Now it freezes on screensave or lock screen overnight about once every week.

Current specs and situation: Linux Kernel 5.12.9, GNOME 40.1 on Xorg, and Fedora 34 as mentioned. Hardware: 6th Gen i7-6500U, 16GB RAM, 512GB SSD, integrated graphics. All of which are working and recognized by neofetch. While the SSD had been heavily used before, when i installed F34, i did a full install from a clean slate. I have been only using it for about 6wks now, and the freezes are a thing I don’t remember happening. None of REISUB, ctrl alt combos or sysrq combos work.
Would love to know what causes the freezes when it screensaves, as it’ll do it when the system is idle or under any load.

Seeing you’ve had it on XFCE and I had it on GNOME, the desktop environment is likely not the issue. My lead idea sounds unlikely and wrong: a kernel bug since 4.16/5.0 has yet to be fixed and caused it

The same behavior under Fedora 34. Occasional freezes (sometimes several times a day), very annoying. No more confidence in this machine. I guess 35 won’t bring anything new. Windows works flawlessly. I am going to go back to macOS, macbook pro M1 Pro ordered … :frowning_face:

I have been in peace with this issue since I wrote my last message. What I made: I disabled the XFCE to perform any powersaving and screenlocking. I do it manually, lock the screen and for hibernation I placed a button on the toolbar. If by the accident I colse the screen on my laptop, then happens half-way hibernation, meaning some drivers shut off, some dont. Fortunately mouse has still been running and I can execute the hibernation from toolbar, wakeup will still work fine. I am hopeful for the future that the hibernation and sleeping starts working as flawlessly as it was years ago, maybe I need do make a clean install- no time for it today.