Fedora 33 | fingerprint reader | not unlocking keyring

Hello guys,

I am using Fedora 33 (fresh install) on a Thinkpad Carbon 8Gen. I have configured my fingerprint reader via “fprintd-enroll”. The finger got successfully enrolled.


  • While I can get past the login screen using the fingerprint, the keyring does not seem to get automatically unlocked and the first application I run cause a popup asking me to enter my password.

Is this an expected behaviour? Is there a way to have the fingerprint automatically unlock the keyring?

Additionally, I could enrol my finger only via terminal. If I try via “Settings → Users” the UI crash when I press “Scan new fingerprint” and I select a finger.

Thanks a lot for your help :slight_smile:

1 Like

I have the same issue, except for that your UI crashes where mine never has. Would anybody know why the login keyring does not get unlocked when scanning your finger?

1 Like

I was pleasantly surprised that the fingerprint sensor in my Thinkpad T14 worked on Fedora 33 and was easy to setup. The problem mentioned seems to be caused by gnome-keyring insisting on a password. Searching a bit online I found multiple mentions of this issue with various Linux distributions.

1 Like

Also fresh install of Fedora 33.

Enrollment via Gnome Accounts settings without issues.

FingerPrint logon in Text Console works as well as in Gnome.

Also got this keyring password prompt when opening Google Chrome after Gnome logon by finger print.

Firefox is not asking though.