Fedora 33 boot stuck at Probing EDD

Installed Fedora 33 in legacy mode along with Win8. Fedora does not boot, only Probing EDD flashes on the screen. I had Linux Mint 20 installed earlier which had also failed to boot (I still have LM20 installation). I can successfully boot to Win8. sda1 and sda2 are Win8 partitions, sda3 is extended partition which has Fedora 33 installation, while /boot is installed on sda4 which is a primary partition. Do I need to reinstall ? I want to keep dual boot for some activities that need to be completed on Win8.

I don’t think I’ve seen that problem before. I think I did once have a problem with the edd probe taking forever on a very old system though. As I recall, you can disable that probe by adding edd=off to the kernel command line.

Tried setting edd=off still does not boot.

Have you removed quiet and rhgb from the kernel command line to, hopefully, see any error messages that may be being generated?

I removed rhgb quiet after that it just says Probing EDD and nothing happens, i waited for almost an hour.

I reinstalled F33 with ext3 for /boot (instead of ext4) still the same issue. Should i try with FAT32 for /boot ? I am not sure what is BIOS Boot as partition type, I was wondering if I can try that?

BIOS Boot (normally just 1 of 2 MB in size) , is a special partition to enable using GPT partition table under BIOS boot mode.

Please check in which mode you are booting with:
UEFI with Secure Boot

And before seeing the boot hangs at Probing EDD, do you see the line of
Switching root.

I think probing edd happens before dracut loads. It is after the bootloader has handed off to the kernel though. It sounds like the kernel is incompatible with the hardware somehow. I would suggest trying a different kernel or some common kernel safe mode options like noacpi and/or nomodeset.

I am booting in Legacy/Bios mode. My exsistingWin8 (which boots successfuly from GRUB) is installed in Legacy mode and F33 is also installed in Legacy mode.

I do not see any line before Probing EDD, infact the Probing EDD is not shown all the time, most of the times screen directly goes blank.

Can i try installing /boot in FAT32 mode?

I tried with noacpi and nomodeset but no change, screen just goes blank after i hit ctrl+x.

No, /boot cannot be in FAT32. You can use the most common ext4 filesystem.

I’m seeing a few references to some recent kernels needing noapic and/or nolapic to boot on some hardware. I guess you could give those a try?

1 Like

Tried both noapic and nolapic (individualy and together) - still does not boot :frowning:

The weird part is i get only blinking cursor and no log even after removing rhgb quiet.

Is there some aditional information that I can share? I just dont want to give up :slight_smile:

Should i try BIOS BOOT for /boot ?

iommu=soft is another possibility. Beyond that, I think your best bet is to try some older kernels or a rescue mode kernel.

iommu=soft also did not work. In the meantime I got Debian installed which is getting stuck at Loading Initial Ramdisk.... I have tried many workarounds for this new error but nothing seems to help.

I almost sounds like a problem that very old computers used to have where the BIOS could not access files beyond a certain sector of the disk. It used to be required that the partition containing the kernel and initramfs be the first partition on the disk to avoid that problem. Seems very unlikely, but is your kernel and initramfs stored early on the disk or towards the end of a very large disk?

In a MBR/BIOS setup, can /boot be installed to an extended partition? I cannot recall anymore.

I always put the extended partition last. I never tried putting it in the middle of the primary partitions like that.

If you are using grub and sda3 is a filesystem that grub can easily work with natively (e.g. ext4), I would try something like the following:

# cp -a /boot /boot.new
# umount /boot
# rmdir /boot
# sed -i '/boot/ s/^/#/' /etc/fstab
# mv /boot.new /boot
# grub2-mkconfig -o /boot/grub2/grub.cfg
# grub2-install /dev/sda
# reboot

You may need to adjust the above depending on the specifics of your system. For example, if you have grub2 installed in a PBR rather than the MBR. Or if you are using some other bootloader.

Don’t run the above commands unless you understand what they do and you are willing to take the risk with your system (I have not tested them; it is just from memory and there may be errors).

I fire up an VM Guest with this storage layout:

vda1 primary 1G not formatted
vda2 primary 1G not formatted
vda3 extended 17G
vda5 logical ext4 /
vda4 primary 1G /boot

The installation went well and booted OK.