Fedora 33 (beta) cannot boot into (even other linux distro's can't boot)

So… Every linux distro + fedora doesn’t boot into this system can anyone help me?

Btw i’m using a hp pavilion 14 laptop.


1 Like

But I am using windows not linux and… I do know what is wsl but how to install it?

(+ My UEFI Firmware is fully updated and I still got this)

Turn off secure boot in your UEFi BIOS and check the boot order for your devices. You can use e.g. Balena-etcher under Windows to write an issue-free ISO Image and try it again. HP machines are working very well with Linux and Windows, I am using it for many decades now.

1 Like

I turned off secure boot but it doesn’t work… Idk what is happening but i’m trying the “sudo dd” command in windows.

So… sorry if i’m being rude but I just installed wsl and I tried to use lsblk and fdisk -l both don’t work so… I tried to access my downloads folder by doing:: “cd Downloads/” it gave me the unknown directory error so I don’t know what to do now.

EDIT: I realised that I don’t need lsblk or “fdisk -l” I just need to input the directory of the drive and done.

See: https://docs.fedoraproject.org/en-US/quick-docs/creating-and-using-a-live-installation-image/#using-fedora-media-writer

Fedora Media Writer is available for Windows: https://getfedora.org/fmw/FedoraMediaWriter-win32-latest.exe (from https://getfedora.org/en/workstation/download/)
Another tool that should work is called Rufus, available for Windows. And finally, there is https://unetbootin.github.io/.

BTW: F33 beta has a bug and currently won’t boot when Secure Boot is enabled.


Yes I have tried without secure boot. And it didn’t work plus let me try that solution you made.

Not working but I just need to use the dd command but I need to write the drive do I just type D: (I know I said on the top that I have the solution but… It just didn’t work)

dd is a command line tool for GNU/Linux. As long as you are on Windows (forget about WSL2 unless you have installed a proper Ubuntu or whatever in there), you need to use Windows tools. I have named three in my previous post.

Look at this: Linux and HP Pavilion 14

1 Like