Fedora 32 Ryzen screen corruption with Xfce

I do not know if this is kernel related or some other component. I have an HP laptop with a Ryzen 3 processor/Radeon Vega graphics. Xfce was working okay with Fedora 31. As soon as I upgraded to Fedora 32, the problems started.

I try to log in to an Xfce desktop, but the screen is corupted. It will start at the top for part of the screen. Then there will be a segment that is offset to the right. Below that, there will be additional segments, each offset to the right. It repeats to the bottom of the screen. I can’t figure out where to click to exit, so I have to use a CTRL-ALT-F2 to get to a terminal where I can log in and reboot.

LXQT desktop and Enlightenment work okay. It seems to be just the Xfce desktop. I’m not happy about this because Xfce was my primary desktop. I don’t use Gnome. LXQT is okay, but it ls not the same. Enlightenment is nice, but it lacks in many respects, especially in being able to use the touchpad with a tap to click like I am used to. What is up with Xfce and how do I fix it?

Did you already try disabling composting to see if that’s it.

xfconf-query -c xfwm4 -p /general/use_compositing -s false

That or running Compton and forgetting to turn the built in compositer off used to cause me problems when I ran xfce.


That may have been it. I renamed the .config/xfce4 folder and tried again last night and it worked. There must have been something in the compositing that was causing this. How would one disable compositing in a session where the screen is corrupted? Can it be disabled from outside the session? I would like to get my old session with its customized panels, etc. back although I could recreate them in the new session. The strange thing is that when I look at the new session, compositing is enabled but it works while my old configuration, the screen is corrupted.

Edit: It worked last night, but this morning when I booted up, the new session also was corrupted. I’ll have to delete the config file so it can be recreated, then turn off compositing and see if that fixes it.
Edit: What changed between Fedora 31 where it worked and Fedora 32 where it doesn’t? I’m wondering if there was a change in the kernel between the 5.5 and 5.6 kernels that could be causing this.