Fedora 32 Gnome Shell extensions not working

Gnome shell extensions are no longer working in Fedora 32. Tried from browser gnome-extension plugin and from the Tweaks app (extensions are disabled when opening Tweaks app).

1 Like

Most Gnome-shell extensions are not maintained by either Gnome or by Fedora. They are developed and maintained by individual developers. So, it’s best to report this to the developer of your extension. They may need to make some changes for Gnome 3.36 that Fedora 32 comes with.

1 Like

you can try with this one…

sudo dnf install gnome-extensions

and it can be used in CLI:

❯ LANG=C gnome-extensions --help
  gnome-extensions COMMAND [ARGS?]

  help      Print help
  version   Print version
  enable    Enable extension
  disable   Disable extension
  reset     Reset extension
  uninstall Uninstall extension
  list      List extensions
  info      Show extension info
  show      Show extension info
  prefs     Open extension preferences
  create    Create extension
  pack      Package extension
  install   Install extension bundle

Use ?gnome-extensions help COMMAND? to get detailed help.

use this TOPIC for any comment…

you also can launch gnome-tweaks via command line and look at any error in terminal…



Thanks hhlp!, this solved my issue.

I have now read (should have done it before, my fault!) in the Gnome 3.36 release notes that extensions are now managed through the Extensions app; unfortunately this app is not installed by default in Fedora 32, and, if extensions are not enabled in the Extensions app, they are all disabled at every reboot (even if you turn them on through the browser plugin).
Hopefully one day Extensions will be part of the Settings panel.

Thank you and regards.

1 Like

It solved my issue too: I tried to remove extension via extensions.gnome.org and it kept re-appearing.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.