Fedora 32 crashes on boot, but not in command line

If you diagnose the problem with the graphics drivers, may I propose installation of RPM Fusion drivers using GitHub - t0xic0der/nvidia-auto-installer-for-fedora-linux: A CLI tool which lets you install proprietary NVIDIA drivers and much more easily on Fedora Linux (32 or above and Rawhide)?

RPM Fusion sounds familiar; I may have used that in the past to install drivers. Looking at the NVidia site, it seems they have released new drivers just last month. Maybe that’s the problem? I don’t know…the graphics card doesn’t even activate when I turn the computer on, I mean the fans aren’t even spinning. I’ll try updating the drivers anyway though.

You can manually boot into multi-user.target (text mode) at runtime:

  1. At Grub2 boot menu, highlight the entry you want to boot
  2. press ‘e’ to edit the entry
  3. append, without the quotes, “systemd.unit=multi-user.target” to the end of the kernel line
  4. presee Ctrl+x to boot the edited entry

If you can boot to text mode, you can furhter:

  • make boot to text mode permanent until you fixed your problem by
    $ sudo systemctl set-default multi-user.target

  • when you need to start GUI, you can run for GNOME
    $ sudo systemctl start gdm

  • for KDE
    $sudo systemctl start sddm

  • you can also check your network settings in text mode. It will be easier if you can have Internet access working.

  • activate your root account by setting the password for the root account if you need access to emergency shell
    $sudo passwd

Good luck!

ps. As part of troubleshooting, remove the add-on graphics card. When the system can boot normally, then you can reinsert the graphics card to check its status.

1 Like

Please avoid installing drivers from the RUN file which is directly obtainable from the NVIDIA site due to its generic nature.

I’ve removed the graphics card and it still hangs up when booting. I booted into command line mode and then did “sudo systemctl start gdm” only to get this message: “Unit gdm.service not found.” I’m now googling that.


My fault, you are using KDE, gdm is for GNOME.

Please try below instead:
sudo systemctl start sddm

Unfortunately this just makes it lock up. Blank screen with only a blinking cursor in the top left corner, doesn’t even respond to Ctrl-Alt-Del.

On your next boot, please check the output of:

  1. any errors in journal, by using a time period covering this recent hang, example below:
    $sudo journalctl --since “2021-02-06 11:00:00” --until “2021-02-06 11:15:00”

  2. the output of lspci -v, expecially the VGA related entries, a sample output from my machine:
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] (prog-if 00 [VGA controller])
    Subsystem: Dell Vostro 3350
    Flags: bus master, fast devsel, latency 0, IRQ 37
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f7b20000 (64-bit, non-prefetchable) [size=128K]
    I/O ports at e000 [size=256]
    Expansion ROM at f7b00000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Capabilities: [58] Express Legacy Endpoint, MSI 00
    Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
    Capabilities: [150] Advanced Error Reporting
    Kernel driver in use: radeon
    Kernel modules: radeon

  3. your kernel version
    $uname -a

kernel 5.10.12 just pushed out earlier today. you might want to update to the latest kernel and try:
sudo dnf update kernel

I personally do not use KDE, I am sorry that I cannot give you KDE specific suggestions.

1 Like

I looked at the error journal from the first time I started it up today, which was right after I removed the gfx card. There were two sddm error messages that popped up several times during that boot: “Failed to read display number from pipe” and “Display failed to start. Exiting.” There’s also a few core dumps that I can’t even begin to understand. After the core dumps and before the reboot I also see this repeated five times: “Process 1084 (sddm) crashed in qt_message_output (QtMsgType, QMessageContext const&, QString const&) clone .cold

1 Like

And also: I tried lspci and it only lists onboard devices. Even when the GPU is connected, it doesn’t see it.

Current kernel is 5.9.10.

1 Like


Yes, this is exactly what it does.

The solution is there … did you try to do it ?

Hmm, OK…I entered “sudo sulogin --force” and got into the console. I’m not sure what to do from here though. I’ll investigate this further…

Something else, because I’m really slow to figure stuff out. I finally figured out how lspci works and ran that specifically on the PCI Express ports.

For port 1:
Flags: bus master, fast devsel, latency 0, IRQ 24
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: [disabled]
Memory behind bridge: [disabled]
Prefetchable memory behind bridge: [disabled]
Capabilities: [40] Express Root Port (Slot+), MSI 00
Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit-
Capabilities: [90] Subsystem: Gigabyte Technology Co., Ltd Device 5001
Capabilities: [a0] Power Management version 2
Kernel driver in use: pcieport

Port 7:
Flags: bus master, fast devsel, latency 0, IRQ 25
Bus: primary=00, secondary=02, sec-latency=0
I/O behind bridge: 0000e000-0000efff [size=4K]
Memory behind bridge: [disabled]
Prefetchable memory behind bridge: 00000000f0000000-00000000f00fffff [size=1M]
(the rest is the same as the last one)

Port 8:
Flags: bus master, fast devsel, latency 0, IRQ 26
Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
I/O behind bridge: [disabled]
Memory behind bridge: f7c00000-f7cfffff [size=1M]
Prefetchable memory behind bridge: [disabled]
(rest is same as before)

I should add that I reinstalled the GPU because I wanted to see if it wasn’t drawing power. It is–I see the fan spin a little bit when I turn the computer on–so that’s not the problem.

I got an update! I don’t know if this was there yesterday and I didn’t notice till now, but: I just now ran lspci again and this time found my graphics card there. Here’s what it says:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Subsystem: Gigabyte Technology Co., Ltd Device d000
Flags: bus master, fast devsel, latency 0, IRQ 29
Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
Capabilities: < access denied>
Kernel driver in use: i915
Kernel modules: i915

So, the card is active and powered up. Now why doesn’t the thing actually work?

1 Like

Wait, that isn’t my graphics card but the motherboard’s onboard graphics. It’s not actually seeing the graphics card at all! I guess this isn’t a Linux or Fedora question anymore then since the problem seems to be the graphics card.

PROBLEM SOLVED! The issue was the PCI slot. I moved the GPU to another one, and now everything works. It boots up into KDE just fine. All I need to do now is update the GPU drivers, and of course Fedora.

Of course, the bad news is that one of my PCI slots is non-functional.

1 Like

Could you please mark this answer as the SOLUTION?

You could go looking for a new motherboard if you are a NVLink enthusiast or had other uses for the broken PCI slot but repairing it would be very difficult. Good luck! :grinning_face_with_smiling_eyes:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.