Fedora 31 Won't Install on ASUS Vivobook Laptop Even Though 30 Worked Fine

I’ve been a Fedora user for some time now and never had a problem with installation, I was excited about 31. I tried to install 31, and after going through the normal install routine, at the point it would normally go the the desktop, it just goes to a blinking cursor, then after a few minutes to a blank screen and never fully loads. I’ve tried installing from a USB, from Fedora Media Writer, and from Fedora Software Center, and even tried upgrading from the terminal to no avail.

Quite frustrating, any help would be greatly appreciated. Incidentally, I’ve been using Fedora 30 flawlessly along with KDE Plasma desktop. Intel(R) Core™ i7-8550U CPU @ 1.80GHz, NVIDIA GeForce MX150 Graphics, 8GB DDR4 RAM

I’m having a similar issue on my Asus Vivobook 15 X512FL (i5-8265U / NVIDIA MX 250)

During the installation I already started having problems. When booting from the stick the screen froze after “Started Gnome Display Manager” showed up. I ended up getting it to work when booting in basic graphics mode from the troubleshoot options in grub.
Even after booting I had problems though. The touchpad didn’t work at all, and during the Anaconda installation it wasn’t detecting my SSD (To be clear, nothinf was detecting it, Nautilus denied its existence).
Eventually I did a succesful install, but booting always booted me in the basic graphical settings and I still had a problem with my touchpad.

These were not problems I used to encounter on Fedora 30…

Yes, quite the conundrum. Fedora 30 KDE worked flawlessly and is awesome. This is a head scratcher. I had the exact same experience, it freezes right after “Started Gnome Display Manager” & just goes to the blinking cursor. Hopefully they get this figured out. I’m looking forward to 31

Try to disable discrete graphics, install Fedora, update all packages and then install nvidia proprietary drivers.

Forgive my ignorance, but how do you disable discrete graphics? I hate to mickey mouse the install. Perhaps better to just wait for Fedora to get this figured out.

Sorry. Some devices allow to set this in BIOS/UEFI.

I figured out a solution. I simply booted up in safe (troublshooting) mode. Graphics were 800x600 which was ugly, but it booted up & I was able to install 31. Graphics went back to normal after install. Worked like a charm. Kind of silly that’s what I had to do, but at least it’s working. So far so good.


Well, I tried this solution earlier too and it worked, but when booting into the normal installed Fedora my display still stayed at 800x600 and I couldn’t change it :joy:
Also I figured out a way to fix the touchpad on my Asus Vivobook 15!
Had to add the following lines to the grub startup command:

quiet splash i8042.reset i8042.nomux i8042.nopnp i8042.noloop

I’m so happy I finally got the touchpad working since that was my biggest concern - I knew the graphics issue had to be an easy fix because of Wayland interfering with the NVIDIA/Intel graphics combo. But I’m also angry that I didn’t figure this out earlier. Two hours down the drain…

Glad that worked for you Meten. For me, 31 is just too buggy at this point. I use KDE and some of the desktop effects weren’t working either. I didn’t even try my touchpad, maybe I would have had the same problem.

Anyway, I’ve gone back to 30 for the time being until they can get things figured out so I don’t have to mickey mouse everything to make it work.

I downloaded the KDE version of 31 and installed without a hitch. It’s working great and given I didn’t want the Gnome bloat anyway, it’s turned out very well. The only caveat is that KDE is not recognizing my Canon Pixma multi function scanner (picks up the printer just fine), but if I can figure that out, I’m good to go. Now I can see what everyone has been talking about, 31 is awesome so far.

Weird that the Gnome version had that bit of funkiness that KDE didn’t. The KDE version also doesn’t have the problem with the special effects that the Gnome version has

so ive ran into same issue during install but even after installing F31 I cant change screen resolution or brightness. only have my default 4k in the list of available resolutions.

How did u manager to fix it?

Ultimately, I ended up installing KDE Fedora 31, rather than the Gnome version and adding the KDE desktop. That too is not without it’s problems as stated earlier, KDE won’t find my scanner. As well, last night as Fedora updated, it started doing some funky things like freezing on reboot, and now having to login into my wifi every time I reboot. Hopefully they’re working on getting out the kinks.

Oh, one more thing I forgot to mention.
Something about the graphics setup on this laptop or the graphics driver on Fedora caused me to still get stuck on “Started GNOME Display Manager” permamently, even after the installation.

Well, nomodeset enabled a really strange graphics mode where everything was stuttery. The settings said the GPU is “llvmpipe” or something like that and the resolution was 800x600.
I found a better fix for it. I don’t know exactly what it does and why does it work, but at least it does. I added
to the Grub startup command.
Keep in mind I didn’t have NVIDIA drivers installed before I did that fix.

So Meten, again, forgive my ignorance, but how does one get to the Grub startup command to change the nouveau.modest=0?

sudo vi /etc/default/grub

or use another editor (gedit maybe)

append the line starting with “GRUB_CMDLINE_LINUX” with


run in an terminal

[ -d /sys/firmware/efi/efivars ] && sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg || sudo grub2-mkconfig -o /boot/grub2/grub.cfg

- last line is ONLY ONE line (from “[-” to the very last “.cfg”) ! -


When entering vi /etc/default/grub, this is what I get:

GRUB_DISTRIBUTOR=“$(sed ‘s, release .*$,g’ /etc/system-release)”
GRUB_CMDLINE_LINUX=“resume=/dev/mapper/fedora_localhost–live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap nomodeset rhgb quiet”

So I think I get that I need to add nouveau.modeset=0 to the end of the GRUB_CMDLINE_LINUX, but how to I get into edit mode to add that line, and second, do I put the -d /sys/firmware/efi/efivars ] && sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg || sudo grub2-mkconfig -o /boot/grub2/grub.cfg at the end of it all?


i have changed my prev. comment., e.g. add sudo and make it clearer

read man vi or use gedit