Fedora 31 WiFi, USB, and Flash issues - Protips for newbies

I’m looking for general guidance on how to troubleshoot issues on Fedora 31. I’m relatively new to Fedora (I did use it like 10 years ago though) and coming from Ubuntu VM that I run on a Windows host usually.

I have Fedora installed on a Thinkpad T590 and the issues I’ve had:

1.) WiFi card drops tons of packets and seems to get a weak signal compared with all my other devices on the network. This does not occur at all when hard-wired into the router. I tried to troubleshoot this using ifconfig and other tools, and I also checked that the driver is the latest for my card.

2.) After the machine is left alone for some arbitrary amount of time, sometimes input from USB devices is intermittently dropping packets - What this means is that for example, I go to bed, I wake up in the morning, and when I try to login to my machine, there is packet loss that cuts on and off when using my external USB keyboard AND mouse, making it virtually impossible to type my password in as packets get dropped. I would not call this lag because the data is lost - meaning if my password is Password123, it may come in as Psswrd13 because as I type it, data is being lost from the keyboard to the OS somehow. This appears as lag in my mouse movements as well. This MUST be some sortof USB issue because this does NOT occur with the laptop’s built-in keyboard or trackpad. So, if I just switch to the built-in devices while this is occurring, there is no longer any loss and I can login just fine.

3.) I need to do a course which requires Adobe Flash. So far, this has been impossible because although I’ve installed packages for Adobe flash, I don’t think the Firefox shipped with F31 supports it anymore. Therefore, I cannot take exams I need to take.

The reality is, each of these issues are unique, and to debug any of them, you likely need more info from me. I’ve spent a fair amount of time trying to troubelshoot these issues myself, and I’m also a software engineer and have been troubleshooting computer issues my whole life. My question though isn’t necessarily about solving these individual issues - rather, it’s about what is the most effective way to troubleshoot issues like this on Fedora when I’m in the moment and I need to get these things working so I’m not missing exams, meetings, and so on, fighting with the OS/drivers/hardware?

Are these issues because I am using too new of a Fedora version? Should I maybe install 30 or 29 instead so that it’s more stable? Any general “protips” for handling Fedora 31 as a daily driver, particularly when installed on baremetal Lenovo laptops, would be super useful. Thanks!


That should not be the case. It works fine here, on Fedora 32. Please open a different topic so we may debug this. Alternatively, try Chrome which (for the time being) comes with Flash bundled in.


This is either a hardware issue, or a driver issue but cannot be debugged unless we have more information. Can you please tell us what hardware this is, and if you notice any errors in the journal?

You can get more information on your hardware and so on using the commands listed here.


If you install adobe flash plugin already to see and use flash run (alt+f2) /usr/lib64/firefox/firefox or in terminal (make sure that firefox is closed before you run this command).
Once you run firefox you need to allow to use flash plugin like on this screenshot on test web page for flash

1 Like

   “Try flatpaks and choose a right hardware” seems to be the answer.  The necessary questions are: “what hardware”, and “how to choose”.  Even if not with WiFi, people there have had troubles with the CPUs (freezes, etc).
   Consider to support ARM, buy an SBC : P.