Fedora 31, nvidia optimus gpu, buzzing noise when using prime offloading

Hi everyone.
I encountered a pretty strange issue after switching to fedora. I am using a Dell XPS 7590 with a GTX 1650 and installed the proprietary nvidia drivers from the rpm fusion repo. I am using the latest kernel (5.5.7) and nvidia driver (440). At first glance everything works fine and I can use the dedicated GPU through prime offloading without issues.

However I noticed that the GPU has started to make buzzing noises even when it’s not being used (nvidia-settings shows 0% utilization). The noise usually starts when there are major screen changes (e.g. when scrolling). The noise is different and louder on some applications like jetbrains IDEs and ghidra (maybe because they are running on the JVM?). Using the nouveau driver or the negativo17 repo instead did not change anything. The only solution I found so far is to use the dedicated nvidia card as the primary GPU instead of offloading. However that causes other issues like jittery scrolling on most applications.

Before using fedora 31 I had kubuntu 19.10 installed and turned off the nvidia card with prime-select intel so the noise wasn’t there. I also have a windows 10 partition installed and did not encounter the issue there.

The only mention I could find of something similar happening was a reddit thread from a couple months ago with no solution. Not really sure if this is a hardware issue, especially because the noise only appears when I use offloading.

This is pretty frustrating because switching to fedora solved all major problems I had with kubuntu. Any ideas on this would be appreciated. Thank you very much.

1 Like

  Hi.  Please, report it to the Nvidia support too.  Even through nouveau has same issue there, the Nvidia should know more.

That’s interesting. Because I have the exact same issue. I think it started with kernel 5.5 as I’m sure it wasn’t there with 5.4. Might be the nvidia drivers though. Hopefully they’ll fix whatever they broke (again).
@mirai you could post the issue at

Hopefully they’ll help with the issue.

1 Like

I don’t think this is an issue with NVidia or IntelliJ. I remove the nvidia drivers (running only with the integrated intel) and the problem was still there. Also I noticed that the issue appears not only with the IntelliJ apps (Idea, CLion, PhpStorm, PyCharm etc), but also other Java applications. Switching to a different java runtime didn’t make a difference.
Running any other applications, even when you using all the cores/threads of the i7 CPU, didn’t make any buzzing noise, nor using the GPU (with games). So it seems an issue showing up only with Java apps?

If anyone has an ideas how to figure out the issue would be much appreciated.