Fedora 31 install hangs on “started gnome display manager”

Fedora 31 installation hangs prior to getting to installer GUI.

So Im using thinkpad t580. Downloaded F31 release yesterday and dd’ed it onto the flash drive. ive rebooted and selected USB flash drive in boot menu. Then selected “start installation” from grub menu. Installer proceed until this line: “started gnome display manager” where it then hangs. So I cant even get into the installer UI…

plz help?

Hello @linuxd3v,
Just out of curiosity, why not use the Fedora Media Writer to create the bootable USB?

I didnt think it was necessary. I always created with dd - seems easy and straightforward.

1 Like

So I was able to install using basic mode (via troubleshooting).
F31 installed ok - but now I cannot change screen resolution or change brightness… wtf

Ive created usb bootable drive via media writer tool as well. - and It’s same result: installer locks at
“started gnome display manager”.

I too have used dd, frequently. There wasn’t anything other than the file integrity on my mind regarding using the media writer, it checks for that which you can also do by comparing the downloaded files checksum against the published checksum. Does the thinkpad have an NVidia GPU?, That may be your issue with not being able to make it through the GUI based install.

Thinkpad t580 has both nvidia and intel gpu.
I never install nvidia proprietary drivers though - and same laptop was working fine with fedora 30 on wayland.

@linuxd3v Hi
I’ve been trying to install fedora with nvidia gpu and intel gpu. I have the same issue as you.
Did you make any progress with the issue?

I had the same issue via a Media Writer USB install. Ended up installing in Safe (or troubleshooting) mode with no problem. Once installed, re-booted to normal. My guess is it has something to do with the dual video card in many laptops.

I used Rufus to create the USD media.
I am able to boot to the live desktop but after a few seconds the system hangs, only mouse pointer moves or stays with “busy” animation and nothing happend. Can’t even start the installation process.

ive ended up installing xfce spin, then installing gnome desktop over it.
no other way worked for me. It really is very messy - I wouldnt recommend it.
Id go with Ubuntu 19.10 until fedora fixes installation process.

My main concern is battery life and found many articles and blog posts that mentioned Fedora as the best distro for battery life.
But I can’t even install it.
I’ve tried Linux Mint and battery gets drained in a couple of hours.

I meet the same problem as you, do you have any solution now? How to change the resolution and brightness?

my xrandr info

xrandr | fpaste


Your description of the problem fits the issues with the optimus card.
I suggest you use the info at NVIDIA Optimus Bumblebee :: Fedora Docs to install the proper drivers and fix your display issues.

Hi all,
I solve my problem about resolution and brightness via install the NVIDIA driver via this protocol Install an NVIDIA GPU on almost any machine - Fedora Magazine

After reboot my laptop, everything is fine. Hope it will help others who met the same problem.

1 Like

My HP ZBook had the same issue with the optimus setup (intel integrated graphics + nvidia dedicated card). In my case it was due to the nouveau drivers (not Fedora specific, I had the same thing with Ubuntu as well). The solution for me was to just edit the GRUB line on boot and append either nomodeset or nouveau.modeset=0 i915.modeset=1. I had to do this for the installation and also on first boot into the new system. Then I installed the NVIDIA proprietary drivers from RPM Fusion which configures the kernel command line to use the nvidia driver instead of nouveau and no more booting problems or crash reports.

This is what I have in my cmdline after installing the NVIDIA drivers: rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1


1 Like

Thanks mihalyr.
I agree as I’ve also seen noaveau crash dumps in the logs.
I think until fedora respins project issues an iso where noaveau issue is corrected - installing with nomodeset and then installing proprietary drivers is the way.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.