Fedora 31:Input box to enter passphare for encrypted installation disappears from boot

After nvidia drivers installation, no input box appears before booting installation to enter my passphrase. I tried on a blank screen to blindly enter passphrase and it worked but this is not nice solution… I wonder if there is a way to bring back input box without removing nvidia drivers


Can you provide the followed information?

  • Did you install the drivers through rpmfuson or gnome-software?

  • Do you have full encryption or only the /home partition?

  • Let’s see your boot parameters with the command

cat /proc/cmdline

  • Let’s list your configs in modeprobe.d to see if you do have some blacklist.conf or nvidia config ?

    ls /etc/modprobe.d/

if you have one of them post output of their content you can do it with the command:

cat /etc/modprobe.d/<name of the file>

  • Let’s check how many /what VGA your system do have.

lspci -vnn | grep -i VGA\ compatible\ controller -A 12

if you did install nvidia driver from rpmfusion (or gnome-software) you can try one thing if you do have a intel CPU+GPU compatible in the output of command above because if we temporally don’t load the nvidia-drm module i.915 from the intel CPU integrated should take up Plymouth (at least it is my thinking not verifired)

Maybe the password request is coming before the nvidia-drm module is loaded or it is failing in some way (Not idea, but we can check if it is so), How? you can try add temporally this parameter
nvidia-drm.modeset=0 at the boot process following this guide,

Note: The change will affect only the first boot after you did push F10 to save and continue the boot procces. The grub menu is hide by default in fedora you can unhide him trough:


  • Press F8 to unhide the menu (F8 has been the key to show the Windows boot menu for many older Windows versions)
  • Keep SHIFT pressed during boot, this fixes the timing problem and this is what Ubuntu does so various forum posts, etc. refer to this


hi xtym thanks for your response

  • Drivers are installed from rpmfusion

  • I have full encryption

    cat /proc/cmdline

BOOT_IMAGE=(hd5,gpt2)/vmlinuz-5.3.15-300.fc31.x86_64 root=/dev/mapper/fedora_localhost--live-root ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.luks.uuid=luks-cbe4c254-d5d8-4ae1-a2e9-f4fa9145247a rd.lvm.lv=fedora_localhost-live/swap rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=0
lspci -vnn | grep -i VGA\ compatible\ controller -A 12
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device [1043:85ae]
	Flags: bus master, fast devsel, latency 0, IRQ 141
	Memory at de000000 (32-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at d0000000 (64-bit, prefetchable) [size=32M]
	I/O ports at e000 [size=128]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia

01:00.1 Audio device [0403]: NVIDIA Corporation GP106 High Definition Audio Controller [10de:10f1] (rev a1)

ls /etc/modprobe.d/
no blacklist or nvidia configs

tried nvidia-drm.modeset=0
as you can see with no result…

nvidia driver is working perfectly later (when the desktop is loaded). I cant see how intel graphics could fix things because they are not connected to any monitor, only nvidia is connected.

Well you do only have nvidia VGA there is not present any i915 module so lets try a couple thing to see if something change, Always with temporal changes like you did before so that we only will test.

One strange thing to me is why the kernel is showing nouveau module Edit: check if it is active or inactive (but can be than it is loaded but not in use it can be check throught lsmod, take a look) I am not sure if it should be into a blacklist.conf or do it be into a file called something like nouveau.conf into the path /etc/modprobe.d/ (at least it is than i imagine not sure because i dont have nvidia)

a) Try disabling temporally nouveau module in the boot


b) If you didn’t have nvidia-drm active, active this one and disable nouveau.

nouveau.modeset=0 nvidia-drm.modeset=1

c) You can try disable temporally parameter rhgb and quiet to see more information remove temporally

rhgb quiet

d) Try disabling temporally plymouth so that you should do the input of your login and pass in plan text (not graphic boot)

rd.plymouth=0 plymouth.enable=0

If nothing solve anything, can you paste here https://paste.centos.org/ the output of this commands after you did boot. dmesg and journaltctl -b

Like said before all the changes in temporal mode to avoid problems


ok, after trying your suggestions found a solution:
All grub parameters stayed, i only have to add
It worked presenting a low resolution (not so elegant) box to enter my passphrase.
Then i made changes permanent by editing GRUB_CMDLINE_LINUX at /etc/default/grub and applying changes (UEFI system) with grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.