Fedora 31: I cannot type uppercase a anymore

I recently upgraded to Fedora 31 and suddenly, I can’t type an uppercase ‘a’ anymore. Whenever I try, I see the letter show up with an underline and at the next keystroke, the upper case ‘a’ diseapears (the second letter doesn’t appear either). The only exception is if I type two successive uppercase ‘a’, I get À.

So if I type XABX I get XX and if I type XAAX I get XÀX

I’m using the Gnome. I have tried disabling my extensions without much success. This seem to affect all applications.

Has anyone seen something like this? any idea what could cause it? Some kind of emoji-typing-booster-thingy that was introduced in the new version of Gnome?

are you sure it is Fedora 31 ?

maybe you can check it with an live cd/usb ?

All what I can think off regarding your topic is:
years ago I had a netbook what showed the behaviour you described.
It was a HW bug.
in other cases during my search to fix it I found that some notebooks were repairable (youtube howto, etc.)

so I suggest to try to first make clear what it is (HW or SW):

  • live DVD/USB key
  • vendor forum
  • internet

be aware of tricky HW bug which come and go e.g. typing 3 letters only in an to short test might be NOT enough …

I finally found the issue: some time ago I tried to experiment with XCompose and although I never could make it work, I still had an .XCompose file in my home directory with my failed experiments. Now for some reason it started to “work” and was the source of my weird keyboard behavior.

I removed the .XCompose file and everything is back in order!

Thanks @sixpack13 for your help!

AaAaAaAaAaAaAa :partying_face:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.