Fedora 31 fresh USB install fails at splash screen

Motherboard: X10DAC (Dual Xeon 12 cores ea, 128GB RAM, 500GB SSD, wireless Ethernet, Blutooth keyboard, and mouse, Nvidia Quadro 4200 video card). Have previously installed Centos 7, and Ubuntu 18.04.3 live without issue (from DVD to other new SSDs).

64GB USB stick used as install media using UEFI boot. Fedora writer used to download and copy iso image to USB 64GB Sandisk.

Live install passes media test repeatedly, but apparently dies after Fedora splash screen. Graphics card is Nvidia Quadro 4200 (cuda capability 3) using dvi to hdmi adapter
Install is from fresh media with blank 500GB SSD available for destination media.

This is my 2nd attempt to try Fedora, 1st attempt was in October with Fedora 30.

Installing workstation version.

I would suspect media, but media tests pass repeatedly,

I would suspect Graphic Card Driver
Have you tried running without Graphic driver? I believe there is an option for that on the GRUB menu before booting commenses.


Many thanks for your suggestion! I will try it and post the result.

Your suggestion worked. Fedora 31 entered its installation menus, and is now installing. Simple solution… many thanks!

1 Like

I’m glad it worked out. Don’t forget to tick/mark relevant post as the solution