Fedora 31 and 32 Anaconda does not see my nvme M.2 drives

I upgraded my system to a X570 motherboard, AMD 3950X, 2 (Gigabyte Aorus nvme Gen 4 M.2 SSD) drives. When trying to install Fedora 31 (or 32 pre-release) Anconda does not see my 2 nvme drives, only the USB drive with Fedora is shown. Mostly when selectinging rescan or another option Anaconda crashes. When I start the Drives app from the live CD both my nvme drives are shown, also sudo fdisk -l shows both nvme drives.
How can I make Anaconda force to see both my nvme drives?

Hello Reinier,

Did you test the media before installing Fedora?

1 Like

Yep, I did, no errors. Also tried netinstall, but same problem. Fdisk and Drives app both show my nvme drives, but anaconda does not see them

If enabled, try to disable RAID for nvme in the bios.

It is disabled…
Strange thing is that Ubuntu, Arch, Debian and Suse don’t have any problem recognizing the drive. Fedora 31(and 32) Drives app and fdisk also recognize my nvme’s from the fedora Live ISO

It looks like a hardware related problem, maybe with proprietary drivers. Check this post from @xtym maybe that will help.

Depending on the operating system, nvme support may not be available.
Other physical systems also have perception problems by operating system, which is due to system compatibility issues. If this is the case, it is best to avoid using the device.

[[simmon@fores ~]$ uname -ar
Linux fores 5.5.5-200.fc31.x86_64 #1 SMP Wed Feb 19 23:28:07 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux]

WoW!! New Kernel - F31 Server

Thanks for helping me with this error, but as I run an AMD board, there is no Intel RST/Optane in the BIOS.
Why are fdisk and gparted and Drives from the Fedora Live CD seeing my drives, but Anaconda not?

From the Fedora Live! environment I can see both my nvme drives with fdisk, gparted and Drives apop, but when I start Anaconda from the same live environment it does not see any of my nvme drives…

1 Like

One other thing is that Ubuntu, Arch, SUSE, all see both my nvme drives, only anaconda crashes and does see them ??

There may be differences between the live environment and the actual behavior. There is no complete system consistency in those areas, and in other Linux you should check the actual installation disk status after checking.

Check dmesg for clues. Anaconda won’t see the drives unless the kernel does.

Thanks for trying to help me with this problem. But what should I do with this long output of dmesg ? All apps in Fedora live see my NVME drives, all other distros see them, only Anaconda does not see my drives.
ASny suggestion what I could do to install Fedora on my drives?

So the final conclusion is that though every other distro installs fine, fedora can’t be installed on my modern AMD 3950x system.
One thing that might be of help in solving this, is that during the install of Suse I get a notification that a “multipath system detected”.
Could this give more direction in solving my problem with Anaconda?

This sounds like it could be a bug. I suggest filing a bug report, bugzilla.redhat.com. Set component to anaconda. Attach the log files found in /tmp/ individually. program, storage, anaconda logs should be sufficient. Also attach dmesg.

It’s actually ideal to do this with a Fedora 32 nightly image since it’s under development and has a good chance of getting bugs fixed soon. Whereas Fedora 31 is done, and all that’s possible is maybe figuring out a workaround. But I suggest using the test@ mailing list, lists.fedoraproject.org for pre-release discussion, or #fedora-qa on irc.freenode.net.


Thanks for your extensive answer! I will file a report later today using the 32 nightly image.

Agree with @chrismurphy, this looks like a bug to me. Certainly worth reporting.

In addition to his suggestion, you can also try a respin of F31, maybe the bug has been reported and fixed (I didn’ search for it) since the F31 image was produced.

See Index of /pub/alt/live-respins for downloads. I assume you are using the standard workstation edition with Gnome, here you go: https://dl.fedoraproject.org/pub/alt/live-respins/F31-WORK-x86_64-LIVE-20200206.iso (built on 2020-02-06).

In case you are looking for the F32 nightlies and don’t know the page yet, here it is: Fedora nightly compose finder


Thanks @florian for your extensive answer and links. Fedora 32 has the same problem. Bug has been reported to bugzilla. Hope they will be able to fix it (soon).


Can you post the bug ID or URL? Thanks

Hi Chris,

Bug ID: 1711571