Fedora 30 new install wifi

I am trying to install Fedora 30 to give it a try. I haven’t used RH since version 4.2 and am serious about Fedora. The install went fine but the initial boot up, wifi will not connect. Since with this a dual boot, I went to POP_OS/Ubuntu 19.04 and dumped out lshw -C network which is below. Any tips would be appreciated.

lshw -C network
WARNING: you should run this program as super-user.
       description: Wireless interface
       product: Wireless-AC 9560 [Jefferson Peak]
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       logical name: wlp0s20f3
       version: 10
       serial: 04:ea:56:b8:15:14
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.0.0-25-generic firmware=43.95eb4e97.0 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:16 memory:b4718000-b471bfff
1 Like



It worked for me. Thanks

1 Like

Welcome to the Ask Fedora discourse! If their answer worked for you, feel free to mark it as accepted via the green check mark on the bottom.


Question: Are these changes also pushed to other spins like Fedora Cinnamon? Thinking about giving it a try.

1 Like

The spin should use the same repository as the Fedora release it is based on.

You can also verify it with the following command:

dnf repolist

I think this topic is a good example why a netinstall has huge advantages: You download the latest packages where bugs have been fixed (or just been introduced).
You can also use the netinstall to choose your DE. no need to download different ISOs…


One other option is using Live respins:


They’re official Live ISOs (done by Fedora Respins SIG) regulary updated to include latest updates, bugfixes, etc.

Here’s some more info:


For a new Fedora user this has been a very informative discussion. The netinstall may be a better option. With this update/fix it repaired broken WiFi which could mean not net access from a normal ISO.

Also, the live-respins, based on the date stamp, may not have the updates from yesterday applied as of yet.

Thanks again, I will probably migrate from POP_OS this weekend.

1 Like

Both methods have their stronger and weaker sides – as usual. live-respins allow offline installation and can be used for disaster recovery – but understandably can’t be updated daily.

Netinstall means smaller initial download and always up-to-date packages. It’s also very good for non-standard installations (minimal install, for example), when none of available spins suits your demands.

1 Like

If I understand your question correctly, with a “normal” iso (meaning the original, downloadable desktop iso) that fired up a Live system you didn’t have the problem because the bug was only introduced later with an update of that package. The next updated then fixed the problem again.

No, sorry, I did not explain very well.
I used an ISO to install on a secondary SSD and was never able to connect to WiFi. The update via CAT5 fixed the problem.

I decided this morning to fully leave Ubuntu/POP_OS and install Fedora 30 with the Gnome Environment. I used the Netinstall, and the initial steps of the install, it would not connect to WiFi. I connected to CAT5, and as it downloaded the installation files, WiFi was available on the first boot.


This link helped me a lot

I had to manually install dkms, git and kernel-devel. (I’m on F30 XFCE)

git clone -b v5.3.4 https://github.com/aircrack-ng/rtl8812au.git
cd rtl*
sudo ./dkms-install.sh

Hi @fedaris! Welcome to Ask Fedora! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so.

Thanks for sharing!

To clarify a bit: the link you’ve posted is specific to Realtek RTL8812AU Wireless card / chipset, whereas @eclecticcoding’s computer uses wifi card with Intel 9560 chipset.

In general Intel’s wifi don’t need additional drivers and work out of the box – this is one of the reasons they are generally considered the best wireless chipsets to use with Linux. But there was a bug some time ago with their firmware, and it looks like @eclecticcoding was bitten by that bug.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.