Fedora 30 KDE fails graphical login after fresh install


TL;DR: When I attempt to log into my account on a fresh install of Fedora 30, the display manager (or maybe some related component) fails. The screen shows the last few lines of terminal output from bootup and brings me back to the login screen. I’m able to login on a non-graphical session just fine.

I’m switching my personal computers back to Fedora after a couple of frustrating months with another distro. I burned a DVD with a copy of the installation image available on the KDE spin page and used a GParted live CD to partition my hard drives. Then I rebooted with the Fedora live CD in place and ran the installer. I selected the partitions I previously created, specified their mount points, and checked the “reformat” and “encrypt” options on all but the /boot/efi and /boot partitions, for which I chose “reformat” only.

I continued the installation and set the root password, didn’t check “Lock down the root account,” and set up my main user account as an administrator (which effectively adds the account to the sudoers file, as I understand it). The installation completed successfully, I rebooted without the live CD, and I was able to enter my encryption password and get to the login screen.

Graphical login fails as I explained at the beginning. If I switch to a non-graphical session I’m able to log in just fine. If I try running sddm I get an error:

(EE) DAEMON: Failed to read display number from pipe
(EE) DAEMON: Display server failed to start. Exiting
Aborted (core dumped)

I tried updating my system and this still happens with all packages upgraded. I ran the verification process on my live CD before installing and it completed successfully. What would cause this problem?

Update: I’ve been working on this for a few hours and may have figured out what causes the problem, but there doesn’t seem to be an obvious solution. I’ve got three partitions I’d like to mount within my home directory: one for Documents, one for Downloads, and one for a second Documents directory containing lots of old files. I re-ran the installation process but mounted these in /home rather than /home/myuser, and graphical login worked fine afterward. I edited /etc/fstab to mount these inside /home/myuser and Fedora crashed when I rebooted. I’ll have to test this out more tomorrow.

I’ve confirmed that setting the mount points back to /home fixes the problem. Is there a known problem with having separate partitions for these directories?

Alright, I think I’ve figured this one out, so this post will be marked as the solution unless anyone has a better idea/explanation.

According to an answer I found on the Unix StackExchange, having encrypted partitions mounted as subdirectories of an encrypted partition is problematic; the partition for the parent directory must be mounted first, then the partitions for the subdirectories. When unmounting, the partitions must be mounted in the reverse of that order.
This is achievable by setting up a login script to mount these directories, but it’s not a convenient or watertight solution. A far better way to handle this case is to mount the other encrypted partitions somewhere else, then create symlinks to them in your encrypted parent directory.
I now effectively have separate Documents and Downloads partitions, even though the directories that show up in my home folder (/home/myuser) are symlinks to the directories mounted in /home.